FRAMEWORK FOR DJs - USB Issues

I’ve had my Framework 16 for over a month now. Got it all set up and all of my media transferred over.

But I have noticed issues with the USB ports while DJing on some controllers.

I.E the Pioneer Rev-7 and Pioneer Flex 4.

There are USB drop outs occurring at random times, causing the music to stop for a second while I am mixing. This becomes VERY noticeable as our jobs are to keep the music playing non stop.

Is this an issue with the Expansion Cards, or maybe a power issue? I tried with both the USB A card and the USB4 slots, the issue is still there.

I would hate to have to return my machine that I waited 2 months to get

1 Like

I don’t know anything about DJing, but I think this will be an interesting thread.

Can you add whether you’re running on Linux or Windows? That would affect any troubleshooting. Additionally, approximately how many times per hour would you say the event occurs?

It occurs once or twice an hour.

I’m running Windows 11 on my Framework 16. And the DJ software that is used is Serato DJ Pro

The only similar issues I’ve had with USB audio/midi gear (and I use a ton of it, but not DJ controllers), across 2 FW laptops, have turned out to be either of:

  1. Bad cable (quite a few times)
  2. Busted expansion card (just one so far)

But sometimes there is a problem with a board. You will probably need to contact real framework support if you can rule out the cable and card. If it’s happening to both of your controllers, it’s probably not their fault, unless non-Pioneer controllers are working fine for some reason

I even got a new cable and tried that. I’ll tried connecting the cable directly into the computer and bypass the USB-C Adapter. I got a new USB-B to USB-C cable and the problem persisted. I switched from USB-A to USB-C, assuming the faster transfer speed would eb able to fix it.

But I was wrong on that.

If you’re not using Bluetooth, try disabling that. Also try different ports. Neither strategy should be necessary, but might be worth trying.

I see on the specs page for the Flex 4 that the power usage specs are strange. It says it can be bus powered and only draws 0.5A, which would be 2.5W. But if you plug it into a power supply, it draws 3A at 9V, or 27W.

Have you tried running it with an external USB power supply?

Doesn’t seem like USB power issues would affect the Rev 7, though, since it can’t be bus powered

There are issues with external enclosures/pen drives dropping out. I get that every few hours. I have no way of knowing if it’s hardware or OS (windows 11).

Same here, running Win10Pro, and has happened on Kubuntu too.
And, when using the ‘Send To’ shortcut to copy files between USB devices, after a few such transfers it seems to have devices still appear in the drive listing in Explorer although they are unable to be browsed when clicked on.
And, a device doesn’t disappear from the ‘safely remove hardware and eject media’ after being clicked, nor does its’ drive letter in Explorer but it is inaccessible when clicked on.
I should investigate and document this, and contact support I suppose, but at this time I’m not using USB drives often enough to catch the pattern of problems.
Cheers

I’m good with the external SSD enclosure in port 1 (rear left). So far so good, a few hours.

Which ports are you using? Port 3 and 6, the foremost USB 3.2 ports left and right, cannot deliver enough power for some devices, other than the USB 4 ports 1, 2 left and 4, 5 right.

I recognized that, when I attached an external Blu-ray drive.

I spoke too soon. It dropped out again though it lasted a lot longer than in ports 2 and 3.