Framework with Plugable TBT3-UDZ

I have a new Framework i7-1280P Professional and a Plugable TBT3-UDZ Thunderbolt/USB-3 docking station. When plugged into the docking station Windows intermittently connects and disconnects with that annoying little dong.

I will pick up a new Thunderbolt cable while I am out today if possible, but is there any other things I should check or do to resolve this issue?

Any input would be appreciated.

Update: I added another USB-C module on the left rear side and plugged the docking station there. It was stable for about 15 minutes before the connect/disconnect cycle started. I have not gotten a new Thunderbolt cable yet.

It may be suspending the connection. Verify you don’t have powersaving on for the thunderbolt dock. Basically sounds like it is “falling asleep” on you.

TL:DR Have you tried directly connecting to the laptop w/o the use of expansion cards?

@ nadb Thank you for the tip. I’ve turned off batter saver and we’ll see what happens.

GhostLegion I don’t think I have a Thunderbolt/USB-3 port except with one or more of the expansion modules plugged in. Have I missed something?

nadb Well that lasted about 5 minutes! Maybe I am missing something. Does the dock itself have a power saving mode?

I found three Generic SuperSpeed USB Hub devices in the Device Manager and unchecked the “Allow computer to turn off this device” in the properties. That’s made some difference (less frequent). I keep probing this path for a bit.

Not on Windows myself so not sure. You should likely be able to see the dock in device manager as a distinct unit. Most docks show up with at least the manufacturers name somewhere. In linux the lsusb command shows the vendor and product number. So the names show up. You should have something that shows as Plugable TBT3-UDZ .

All 4 ports are TB4 certified, the USB-C cards just pass-through the signal. The other cards are true adapters, converting Thunderbolt into HDMI, DisplayPort, etc. To direct a comment towards a specific user, you type"@" then the username with no space @John_Thompson

Additionally, as was mentioned in the thread, it might be worth your time to update to the beta BIOS and install the driver package for the laptop if you haven’t already.

Continuing the story! Worked with Plugable support and followed their instructions. Pluged directly into laptop bypassing the USB-C module. Same issue. Used original TB-2 cable supplied with the dock and a 3rd party TB-3/4 cable. Same issue. Updated the BIOS to version 3.06 and Plugable’s support recommendation. Same issue in all scenarios.

Now with the new 3.06 BIOS installed the docking station is not even showing the the Device Manager when plugged in. Also, a new incident is happening when devices are directly attached to the laptop (e.g. USB-A memory stick). They now intermittently connect and disconnect making the laptop “unconnectable” in a reliable manner.

I am very frustrated and dissatisfied right now.

@John_Thompson – Yeah, if you have other devices that aren’t thunderbolt that are disconnecting and reconnecting, that’s some problem that support needs to help you with.

I have the same dock, and they linked my problem above. I was able to get it to work much better by removing the expansion ports.

The thing that really helped me with my troubleshooting was using another computer with the same dock. My work macbook works just fine with the same dock and cable, which helped me narrow the problem down to the computer. You’ve done something similar with your observation that a completely separate device (memory stick) won’t stay connected reliably.


@John_Thompson Definitely reach out to FW support, this is where they need to step in now.

1 Like

@John_Thompson have you tried tweaking the PCIe Power Management in the Windows advanced power plan settings?


Or making sure the USB controllers are not allowed to be shutdown to save power ?


1 Like

Thanks, Jean-Marc_Le_Roux, I have those options set as you indicated.

Matt_Jones1, I have a support ticket open with Framework. Thank you, too!

So far very little progress has been made. I followed Framework support engineer’s suggestions and troubleshooting steps. The left side port behave better than the right side ports lasting about 15 minutes or so before starting to disconnect/connect.

All Framework and Intel drivers are up to date, BIOS has been updated to 3.06.

I am thinking it’s best to return to docking station and try another model/brand before I pitch the laptop out the window. Any recommendations?

This process reminds me of the early days of PCs when you had driver/DLL hell and had to change jumpers on the motherboard and peripheral cards. :slight_smile:

I ran into similar issues with the TBT4-UDZ . Tested 4 or 5 docks settled on the OWC thunderbolt dock (thunderbolt 4). The only does not do well is on a reboot or cold boot while connected it won’t see any of the displays. Hotpluggong or power cycling the dock fixes that (I think this is actually a framework bios issue). Outside of that it wakes from suspend without any issues, screen locking works without issue, displays are very stable, peripherals don’t drop. Very stable power delivery, and actually provides sufficient power for the i7-1260p to not be affected by having to pull battery power to make up for a shortage. Very pleased after almost throwing every other one through a wall.

nadb Is it this one? OWC Thunderbolt Dock, Compatible with M1 Macs, Thunderbolt 3 Equipped Macs, and Thunderbolt 4 PCs

OWC Thunderbolt 4 Docking Station on Amazon

@John_Thompson yes that is the one.

nadb and all who offered me assistance, I sincerely thank you!

I took a risk and bought another Plugable docking station but this time I got the UD-ULTC4K model. I plugged it in this morning and it has been working flawlessly all day long.

Should this purchase go “unshinny”, I’ll send it back and the the OWC model.

Thanks, again!

1 Like