FW16 and Kubuntu 24.04 problem


Received my FW16 (AMD 7940) 2 days ago. Very pleased by the PC itself, exactly how I expected it. However I have a problem : I have installed Kubuntu 24.04 twice already, copied a lot of files and suddenly the system doesn’t work.

First time, it hanged in the middle of a file copy and then I was unable to boot it again.

Installed a Kubuntu 22.04, no problem, did not do any copy but rebooted several times. Since I don’t want to upgrade from 22.04 to 24.04 (when the upgrade is made available) I would prefer to start directly with 24.04.

So I tried to reinstall it. It works very well but after some time and a few reboots, now when I power it on, I see the FW logo then the screen goes black then I see a backlight and… nothing. I waited for a long time, no change. Same symptom as first install.

I haven’t seen such a problem in the forum yet. I experienced once the track pad problem which disappeared on next reboot.

I upgraded the BIOS to latest (3.03?) using fwupdmgr.

Any idea of what I could try, at least as a workaround? Looks like a disk problem (bought a WD black sold by FW)

Just as I am typing this message, I tried to power it up again to see if the leds on the side were showing anything.
1st time, I saw one red flash before and 1 red flash after the FW logo and the computer did the same hang.
I tried again, no led blink, no boot.
Third try (don’t ask me why I still try), no led blink but now the PC has booted again!
So it seems like an intermittent problem. If there is any log I can grab to help debug this problem, please let me know.

Thanks for your help,


Try looking for an nvme firmware update from your manufacturer. They might not post it to LVFS.

Thanks Mario, nice idea, wouldn’t have thought of it. I’ll look up tomorrow.

Did the FW upgrade but problem persists.

I think you should contact FW support then.

So I contacted support. After installing a normal ubuntu (with Gnome) it works ok. When I switch to sddm (or LXDM which I also tried) then I’m back to hanged boot.
In order to boot, one can press ESCape ONCE when the FW logo appears, select 2nd option (advanced options for Ubuntu) then 2nd option (recovery mode) then choose resume (first choice). So the disk seems out of concern, rather a software problem.
Going back to gdm3 works again (but no KDE/Plasma session because I can’t choose). And since Gnome is not an option for me, I’m still stuck.

1 Like

It’s probably this:

Same issue here. I think it’s sddm. Currently looking for a way to get gdm3 to launch Plasma.

@Mario_Limonciello @Jeff_Trull Thanks for the pointer Mario. I made the following change and it seems like sddm is now working. Just booted only a few times but seems promising.

I changed the file /usr/lib/systemd/system/sddm.service and added:

  • In the [Unit] section, I added systemd-udev-settle.service at the end of the After= line
  • I added a line Wants=systemd-udev-settle.service

I’ll report again in a few days if the problem is solved this way.


I did the same, reboots successfully (if slowly) now.