FW16 Batch 6 Guild

Yeah that is quite a lot. I hope that includes insurance.

Mine’s out for delivery today, so the question now is will they leave it on my doorstep or not (I’m not at home - I didn’t think to have it delivered to the office, regrettably). I may go home early today…

shipping in bulk and palletized based on final location can reduce cost greatly. wouldn’t be surprised if their cost is 1/2 or less that amount. I know when I worked for a huge company that shipped tons of packages FedEx at one time offered employees of that company 40% off personal packages up to 3 a week.

Arrived at work today yay!!

All set up now. I had a delay when it wouldn’t boot to BIOS - it just showed the red/blue flashing LED, but after re-seating the RAM it booted up ok (thank goodness).
I went with the Rufus USB install, and offline Win11 install (since once online it updated everything anyway).

  1. Love the screen & resolution, great for 3D CAD (tested it quickly with Fusion 360 - before installing SW)
    Update - Solidworks & Visualize 2023 now up and running no issue
  2. Speakers sounded good to me.
  3. No complaints with fan noise - in use I always tends to max out cooling no matter the machine - but this is quieter than what I am used to.
  4. Build quality was great - considering the multitude of parts that can be fastened and unfastened - and though one of my spacers next to the trackpad was slightly warped (0.2mm), and can move laterally about 0.3mm - I’m more than happy with the overall fit and finish, given tolerances involved.

Now just need to get a bag / sleeve for it all.
Samsonite Guardit 2.0 Bailhandle 17.3", will add MAPBAGRAG sleeve later


LOL, somehow mine went from being out for delivery in a suburb a few kilometres from my house, to being back in Botany 300km away. Singing too-ra-li oo-ra-li addity…

Hey all, just gonna add a poll to see where everyone is at now with their order

  • preorder confirmed
  • preparing batch email
  • charged
  • shipped
  • arrived
0 voters

Pretty much all of Batch 6 orders should be either shipped right now. Please send me a DM if you are Batch 6 and have an issue.


I’m replying to you on it! Got it Friday, though FedEx pulled some typical BS, still much faster than many it seems.


Fortunately, my order arrived late Friday. Had to look at the box and admire its contents until my 2230 drive and RAM arrived from Newegg. Showed up today (Monday).

Installed both drives, RAM and rearranged the spacers a little to get them to sit a little more flush on the laptop.

Luckily I had a USB-C Hub that Windows auto-recognizes (WavLink I think) ethernet port on it. Surprisingly, only the rear left port would power the USB-C Hub and the laptop. The Network port kept resetting itself when it was plugged into the middle left port.

Originally tried the 60W Framework charger with the hub and it powered the laptop ok but the hub kept resetting.

Elected to try the 180W Framework charger with the USB-C hub (though the thought went across my mind that it might be too much power for the hub; rolled the dice and miraculously no smoke escaped) Kept resetting the ethernet port on the hub though, powered everything down, changed it to the rear left port and it came to life with the FW16 like it was no problem.

My old Win11 USB installed in record time and I did not have to the the offline account install. Took way longer to fiddle with everything tonight, now I need to sack out to wake up in 5.5 hours for work. Thanks for the hard work getting things pushed along.



Mines listed as being out for delivery today :upside_down_face:

Now to stare at the road outside all day :rofl:

Same, I’m at work so I’ll have to wait until I get home to play with it :roll_eyes:

Woohoo, just shipped :partying_face: :partying_face:
Expected for Friday, I can’t wait to get my hands on it !!!

1 Like

Hooray, mine arrived 2 minutes before I got home from work. Luckily I had my Dad waiting in for it :laughing:

1 Like

Sorry – been working heads down for a few days.

@Keith_Andreano @Igby The initial reasoning was equally to workaround the missing drivers in the Windows 11 setup and because I have a somewhat irrational distaste for MediaTek anything. (@Wolf_Trabeitt’s post does overlap nicely with my “justifications” though).

Separately I also wanted the setup account to be a non-MSA account … sooooooo I really didn’t need to workaround the missing drivers since the non-MSA workflow involves both bypassing the network and then disabling the adapters during setup. ¯\_(ツ)_/¯

Still dislike MediaTek though.

Wonderful, FedEx stole/lost my FW16…
Last 3-4 times they were the ones delivering, I never received anything.

Oh no, that is heartbreakng. I hope you get a replacement and maybe some justice soon

End of the story: somehow my package was shown as delivered to a receptionist 3h30 ago, while it was still in the delivery truck :person_shrugging::person_shrugging::person_shrugging::person_shrugging:

I’ve got the DIY Edition.

  • Ryzen 9 7940HS
  • 2x 16GB Crucial DDR5-5600 (bought separately)
  • Crucial T500 NVMe SSD 1TB (7300/mbps read speed, also bought separately)
  • Modules: USB-A, USB-C, Audio, Micro-SD and Ethernet… will get another USB-A and USB-C later
  • No RGB, No Numpad (I barely use numpads anyway)
  • Installed Fedora 39 on it.

So far I’m very happy about it.

One thing I’m kinda curious is, the fans are either dead silent… or dead… I barely feel any air current from the exhausts and never heard the blowers rev up.

Yep, I think it’s mainly just quiet. Computers have come a long way in this regard since apple raised the bar with their m1 laptops.

so you did get it after they found it in the truck? (being hopeful)

they are quite quiet. barely a thing doing basic. when I ramp up some benchmarking (make --j8 of gcc) CPU throttles to 100 degC and the fans are still not that loud but can tell they are on and air is blowing out the sides.