Haiku: An OS for Framework?

I am currently a Mac user who is considering jumping ship.

Whilst there are plenty of Linux distros around, I have fond recollections of a year spent using an operating system called BeOS at the turn of the millennium. Sadly I suffered a break-in and the BeOS computer was stolen and I went back to Windows, until switching to Mac. That my time with BeOS was so cruelly cut short makes me yearn to have another go at it. Now that Haiku - an operating system inspired on BeOS - is approaching its 1.0 release - I am looking at acquiring a system that can run it.

I am therefore keen to hear any experiences or research in trying to boot and run Haiku on the Framework. Is it even possible at this stage? I am thinking the Thunderbolt ports - amongst other things - may not yet be supported.

Otherwise I think Haiku would be an excellent match with the Framework. Of interest to those calling for different Framework mainboard architectures, there are active ports for ARM and RISC-V.


Haiku does not support newer tech very well and I think it is kind of foolish to buy something cutting edge and then try to run something like Haiku on it. That said, there is NOTHING wrong with someone doing that very thing.

It is just that it would probably make more sense to buy a used Thinkpad and run it on there. The x30 line is still pretty popular and all the parts are still available for it.

Or buy the Framework, run Linux on it, and run Haiku in a VM. Get all the benefits of your hardware being fully supported, and a super stable Haiku.


Alas! In my testing the Haiku bootloader (UEFI compatible, Secure Boot enabled) can’t load up the kernel over USB or from NVMe.

I blatted the latest nightly anyboot image to a partition on the SSD, and it never gets past the first boot phase.

Unfortunately, on-screen debug logging doesn’t even start before it fails.

I’m still hopeful though!


I agree that the best course of action to try Haiku is to get a suitable used machine, ideally with reference to their hardware compatibility guide.

As for me, I still have a 12" MacBook from 2016 which works still. Whilst not a state of affairs that will last forever, I will keep it whilst it runs the current MacOS. It is getting increasingly inadequate in the face of MacOS bloat, and when it stops getting updates, Haiku is on the shortlist.

Hope springs eternal! It’s great to hear you have had a go at it already, I await reports of further installation attempts with bated breath…

Incidentally, from the Wikipedia page:

The modular design[16] of BeOS allowed individual components of Haiku to initially be developed in teams in relative isolation, in many cases developing them as replacements for the BeOS components prior to the completion of other parts of the operating system.

In other words, the design philosophy employed by BeOS (and subsequently Haiku) mirrors in software that of the Framework hardware itself. A match made in heaven, you might think.

Recent Haiku nightly images boot fully to the desktop. I had tried for months but it would hang up late in the process, apparently when selecting a video mode. That said, mouse movements and clicks are extremely laggy (USB mouse, trackpad did not work) and it’s not very useable as such. Still very good to see and shows the Haiku team is catching up to more modern hardware.



This just isn’t true. Haiku runs great on most Ryzen desktop systems, for instance. I run it myself on an Ryzen 3700X system, and it works fine. (I had to make some fixes to the WiFi stack for this hardware, but it at least booted on the first attempt when I got this system 2 years ago.) Other developers and community members have similar hardware.

This is far more debuggable than the problem @DHowett ran into where no icons lit up; you could have bypassed this problem entirely via the bootloader options, and reported a ticket that we could have looked into. But at least it works now, so that’s great to hear :slight_smile:

Most probably this is the general bug seen across all 11th-generation Intel chipsets, which there is already some idea of what the cause might be. One of the other developers should be getting a new laptop with such a chipset, and so hopefully that will be resolved before too long, too.


Thunderbolt hot-plug does not work on Haiku, but “cold” (i.e. before boot)-plug does; or at least it does on Apple hardware with Thunderbolt, I’m informed.

1 Like

Happy to hear! I have played with Haiku a bit and I really liked it.

Have any of you heard of Serenity OS? If you like Haiku, you might really like that as well. Great developer behind it who video stream himself working on it.

(I’m one of the Haiku developers.) Yes, I’ve heard of SerenityOS.

It’s interesting project, but they seem to be trying mostly to build “everything from scratch” in terms of the base system (i.e. not even using common components shared across Linux/FreeBSD/Haiku/etc. like ACPICA.) Which is a neat way to learn, but not really a viable way to build a general-purpose for-all-users OS like Haiku is.


If anyone gets Haiku OS running on the Framework laptop natively please share it here! I would be really interested what all works and what doesn’t.

Thanks for chiming in here! Awesome to have you with us!


Thanks very much for the reply. I did try many boot options with the older nightlies including failsafe video modes (I’m a Be user going back to '00 and know the drill) but could not get to a desktop. If it’s of interest I could reinstall an older nightly and recreate this issue.

I dual boot Linux and Haiku actually on my Framework laptop (and am also a Haiku developer). I actually developed + tested our signed EFI bootloader process on my Framework laptop.

I’ve been working on the bug @waddlesplash mentioned, but haven’t figured it out yet. Something to do with how the 11th gen stuff calculates cpu clock frequencies makes us see 39.00-41.00 Ghz which throws off timing on polling hardware.


This is all very exciting. I hope that Haiku becomes an officially recognised OS on Framework, to the point that it becomes a factory option.

Many of us consider that Haiku is the best hope for a mainstream desktop open source system. This assertion is based on Haiku having avoiding the fragmentation that has plagued the linux scene and it being a desktop focussed system rather than a “jack-of-all-trades, master of none” which is used on everything from internet appliances to supercomputers. The same applies to the software, what some may call lack of choice is to others a more manageable number of options in any given category. Linux has certainly had long enough to become a viable desktop platform, but made minimal inroads so far.

I am not making the above comments to start a flame war, however perhaps a little provocation might encourage more people to try Haiku with an open mind!


fwiw, the Haiku OS nightly image boots up to the third icon, then stalls, on the 11th Gen Intel® Core™ i5-1135G7 Framework Mainboard. I booted from a USB 3 stick attached to a USB-C hub.

I really enjoyed Haiku R1/b2 when I tested it on an old Dell throughout 2020, so I’ll definitely be wanting to give R1 a shot when it comes out. It felt the snappiest out of any OS I tried on it, including Puppy Linux. I guess part of that is how light the requirements are and the other part is that it let me overclock the panel to 85Hz, something that made it feel like it flied. I also just really liked the GUI it had, hopefully Haiku R2 keeps it at least as an option.

1 Like

Got Haiku Nightly (hrev56504) installed on a 12th Gen 1240P an hour ago (took me some time because of the latest DriveSetup bug which had not yet been fixed when I started my first unsuccessful installation attempts). Ethernet expansion card works out-of-the-box, same with the AX210 wifi card - however, a network connection works only for a couple of minutes (happens with both adapters - I see bug reports in the future :smiley:). So far, I haven’t observed any of the CPU clock inconsistencies of the 11th Gen framework laptops (it shows 2.1 GHz consistently). 16 cores in ActivityMonitor - that will take some time to get used to. The touchpad doesn’t work after each reboot and - if it works at all - tap-to-click is only recognized sometimes, a right-click never. So, to conclude, I’ve had much worse experiences with installing Haiku on a new computer in the past :innocent: .


I’m sorry I didn’t respond sooner to this, but I think this is awesome. Haiku is a topic of much interest in many of the circles I frequent. I personally find it to be a very compelling OS and I hope that your owning a Framework laptop continues to benefit Haiku!!


By the way, this was fixed recently via https://cgit.haiku-os.org/haiku/commit/?id=2e69f2b076f89421ca3ff03521ae87b612c8926d :slight_smile:

Haiku now runs on the 11th gen boards as well.

1 Like

Yes, noticed this going through the source activity log after posting here. A pleasant surprise after being on vacation for a couple of weeks - right on time for my new Framework laptop :wink:. Thank you very much!

Unfortunately, I’m still encountering the issue I reported in October of last year–when I got my Batch 3 11th gen!–where EFI boot just doesn’t work as of hrev56521.

The EFI loader draws the first frame with all of the icons, but the kernel doesn’t get far enough to even start debug logging. jessicah thought that might indicate that we never hit ExitBootServices or that ExitBootServices was failing; this is true with any number of expansion cards (including 0), with SMP disabled, and with or without the 4GB memory limit set. There’s not enough debug logging beforehand to determine where exactly it fails.

I was briefly running a build with debug logging that I’d added, but it was not enlightening.


  • i7-1185G7
  • WD SN850 @ 1TB
  • 2x Crucial CT32G4SFD832A.C16FE for a total of 64 GiB RAM