Has anyone tried installing ubuntu 18.04?

I know 20.04 is working but how about 18.04?
I attempted an install from a usb stick I used on other PC’s

18.04 booted, showed the intitial screen but there was no touchpad response.
Not sure if it is me or if 18.04 just won’t run.


We would expect that the kernel in 18.04 is too old (actually, 20.04 is too old too until 20.04.3 is released). We recommend kernel 5.12 ideally, or at minimum 5.11, so you’ll want Ubuntu 21.04.

1 Like

Normally when the kernel is the issue and a newer one is recommended it has to do with drivers/firmware included in the newer kernel that are not available in the older kernel. As the Framework is using current hardware, I’m fairly certain this is the exact reason.

I myself would prefer to be on a LTS version. I have not found Linux to be very reliable when on a rolling like release cycles.

1 Like

I don’t know about 18.04, but I originally tried installing on 20.04.2 and ran into blocking wifi problems during the installation phase. However 21.04 installed smoothly with everything working right out of the box.

I did run into a hardware issue with the trackpad not registering clicks but it started working after two dozen clicks or so, and there hasn’t been a problem since.

Unfortunately, my work requires using Python 3.8 because reasons, and it’s not available on Ubuntu 21.04. So I plan on installing 20.04.3 as soon as it comes out and will report back. The expected release date is 8/26, see the link below, so we’ll know pretty soon if this version is compatible.