Having audio issues,huge interrupt load

Hello, I’m just finishing spending the past month setting up my new top-tier batch 7 frame.work laptop, and I’m recently having some audio problems. Any idea what’s going on here and how I can further characterize it?

After taking the previous measurements, I rebooted and started playing a Spotify selection like I was doing earlier, same issue seen.

The Resplendence Latency Monitor is my measurement tool, FYI.

Then, I started streaming Spotify from another machine and remotely logging in via Splashtop, wasn’t getting the same audio issues.

image

Here are today’s readings after doing a Webex followed by a Zoom meeting.

@nrp any comment ?

image

After a day of work, little audio, many zoom and webex meetings :

On support’s advice, I tried disconnecting my Dell U2421HE hub monitor with secondary DisplayPort MST monitor U2419H connected.

Also, I made a change whereby Firefox can now run across multiple CPU cores as I noticed that the CPU was pegged at 25% (on a quad core system), now it consumes more than 25% when busy.

Here are the numbers I got : better (I noticed audio dropouts when I connected my Razer Kraken 7.1 Chroma headphones to the hub monitor, but not when I pulled the USB-C to the hub monitor and plugged the headphones directly to the frame.work PC)

Laptop is running with only Wifi connection, pulled out USB-C cable, only have Razr Chroma headphones directly to USB-A, this is the only physical connection to the laptop. I’m watching a YouTube video and I’m hearing audio pops and drops.

I plugged the USB-C to my Dell hub monitor, with MST DataPort connection to a second Dell monitor.

More significant temporary freezes (Ctl Alt Del not working, Alt Tab not working) more prevalant.

After watching a YouTube podcast, USB-C connected to Dell hub monitor and secondary MST DisplayPort Dell monitor, headphones still connected to laptop:

Just attended a one-hour Zoom meeting, getting lots of audio pauses (literally 20 second pauses when even doesn’t work and Ctrl Alt Del doesn’t automatically respond. My Task Manager says 100% CPU is being used, which is highly unusual. The machine is now quiescent but is still showing at 100%y, with system interrupts showing 99.6% CPU utilization.

Still having issues. Charging from external battery to usbc, attending Zoom meeting, plugged mobile phone in usba, Pioneer RayZ earbuds plugged in via lighting/usbc conversion cable. Lots of audio dropouts experienced.

More problems. Started with USB-C connected to Dell USB-C hub, withdrew USB-C while streaming YouTube video, dropped down to Wi-Fi and started LatencyMon, results shown below:

Do a clean rebuild. It’s what I’d do.

I already had my geek Squad tech agent do a clean rebuild two months ago, same issues persist.

Support says they cannot help and that it is due to my peripherals, but I have no peripherals plugged in other than my headphones.

I tried a few other things, I unplugged my headphones and plugged in my USB-C connection to my two Dell monitors (DisplayPort MST enabled for the second Dell). I got occasional audio dropouts, but nowhere near as bad as when the Razer headphones were plugged in.

I also tried disconnecting my USB-C connection and Razer headphones, just doing Spotify to onboard audio, and although the CPU utilization remained high, I didn’t notice any audio dropouts.

I’ll try calling Razer support, but they will likely push back to the laptop manufacturer :frowning:

In this next exciting installment, I have my frame.work connected via wifi only, no external connection other than my Razer 7.1 chrome headphones plugged into a USB-A port. I’m getting audio pops/drops all over the place.

SpeedTest Ookla results : 69 Mbps down, 76 Mbps up, completely sufficient for one Spotify channel.

To close off this thread, I upgraded to a Razer Kraken Chroma V3 HyperSense headset and the system responded much better, audio pops/drops stopped.