HDMI audio output?


Has anyone gotten HDMI audio output working with the framework?

I have tried different monitors/TVs. It doesn’t show up as a sound option in Windows 10, and it doesn’t transmit anything. I’m using the same HDMI cable I use with my camcorder for video capture where it carries stereo 16 bit/48 KHz PCM audio.

I installed the driverpack on this website, and also tried driverpack solution too just to see if anything was missing. I am using the USB-C/HDMI adapter that comes with the laptop and plugs into the side, not my own.


1 Like

Just tried real quick, and my XG270HU monitor is recognized as a sound output for Windows without issue, either over the HDMI expansion card or through my generic USB-C hub.

Does this occur as well with the Beta driver bundle here: Public Beta Test: 11th Gen BIOS v3.03 + Driver Bundle 2021_08_31

No change.

I checked device manager. When I tell it to show hidden devices, intel hd audio shows up. Which I imagine is HDMI audio, but windows update cannot find a driver for it. Same if I use Intel’s own tool on Intel® Driver & Support Assistant - it says I already have everything, besides some unrelated bluetooth driver that could be updated. I’ll keep digging.


A hah, fixed!

I removed the Intel High Definition Audio manually by right clicking it and going uninstall, after going view → show hidden devices in device manager. I went to Download Intel Drivers and Software and grabbed the beta driver for the Intel Iris XE for my version of windows 10, and it worked. The driver support/assistance page/application was useless, but the Download Intel Drivers & Software page led me to the ability to manuallyu download & install the driver I needed and it worked. I have HDMI audio now! I hope this helps someone else.



No HDMI audio for me either on Windows 10 or on Ubuntu 21.04. I tried Louis’ fix and did not work for me. I do have a workaround though…I have a Lenovo USB C Hub w/ a HDMI port on it. This works fine on my Framework and I get audio over HDMI on both Windows 10 and Ubuntu 21.04. Hope a fix is coming for the Framework HDMI port audio as I was hoping to get away from carrying around a hub by being able to choose my own ports.

I also get no sound via the Framework HDMI card on some devices. It works on my monitor and fairly old Samsung TV, but it doesn’t on a newer TV (LG C1) and older AVR (Yamaha RX-V781). Doesn’t matter if i output via the AVR or TV speakers. It works with my deskop PC (nvidia HDMI output).

I tried multiple GPU drivers (101.1121, .1404, .1631) and even upgraded from Win10 to Win11 in between. It works from a USB-C HDMI dongle, but of course thats not a solution.

When i’m connected to the AVR, it just doesn’t play sounds. When i’m connected to the TV an error comes up, when i try to play test-tones “Failed to play test tone”.

Any ideas?

1 Like

I too am having difficulty with my HDMI. I can get picture on my TV, but no sound. I have reported this and they are sending me lots of tests to do. However nothing seems to work. I suggested that they send me another HDMI port. But they say i have to do more tests.

Has anyone got it working OK?

My old Toshiba laptop has no problems with HDMI, I can play video on the TV from that laptop. With no sound issues.

They now are sending me another HDMI socket.

We will see how I get on with that.

1 Like

Unfortunately that HDMI socket arrived today, and is worse than the one I got previously. So I have told them, and sent a photo of the image on the TV. And there is no sound to the TV.

I hope i get it sorted soon

It’s been working perfectly fine for me strangely.

Very good Shiroudan.

I hope mine gets sorted soon.

1 Like

They sent me some more tests to do. However the original HDMI socket is now as bad as the new one, in each socket.

The old Toshiba is working fine.


They are now sending me another HDMI attachment.

So i found some time to play around with that Framework HDMI adapter again. It still doesn’t work with Windows 11, newest Intel Beta Driver installed. It works more or less on the Framework Laptop with Ubuntu 22.04, sound output only is active when something is played. Normally it should be active all the time when plugged in.

Then i tried the adapter itself on a different device (SteamDeck, SteamOS) and it works like a charm. So i really don’t know what’s the problem here. Either way it would be great if this gets fixed somehow :wink:

1 Like

Well i was asked to do all sorts of tests. Nothing made a change to doing HDMI in Windows.

Then they sent me another laptop, as they said they didn’t understand why it was happing to me. Then as that didn’t work, i was told to send back the laptops for a full refund.

So I am sad that i can’t use a Framework laptop to run HDMI in Windows.

I quess I will have to wait until they are making a laptop without this problem.

1 Like

Update from my side:

I had some troubleshooting with the support, including using the Intel Driver Assistant. I don’t think that helped, because my GPU driver was up2date (currently using But i tried other ports on my AVR and TV and sound did work on those (TV just stereo, AVR 5.1). So no idea what happened and why some ports don’t work. I will update if i ever notice this problem on other devices again.

1 Like

I’m having the same issue with my new 12th gen. I can get Audio/Video through my Thunderbolt dock, but only video via the HDMI expansion card.

Confirmed all drivers are up to date, windows updates all up to date.

Hi @kitch have you been in contact with Framework, and how are you getting along with the issue.

Mine was sent back, and I don’t own a Framework laptop now.


Hello Louis (i’m also a board repair technician in France) and the community,

I can’t have HDMI audio out from Intel 11thGen board when using Linux.
If i use Windows 11, no problem.
With Linux i tested :
ArchLinux - Kernel 6.1 - Gnome - Alsa PulseAudio - Xorg Server
ArchLinux - Kernel 6.6 - KDE - PipeWire with Alsa & Pulse modules - Wayland
The HDMI Audio Output is well recognized, the system show that sound is getting outputed but no sound from the speaker of the TV / Projector. If i plug some speaker from Jack, it works, from Bluetooth it works…

I have an AMD Ryzen framework too, no problem with Windows 11 and Linux to have audio on HDMI.

It’s really a bummer because i would like to recycle my Intel 11th Gen board as a media center with Kodi / Karaoke Mugen etc… And i don’t want to install Windows 10/11 on this.