High Battery Drain During Suspend (Windows edition)

OK average of 16%/Hr so may get some 6 hours > not so bad :slight_smile:

Yeah I’ll do some 30 minute “normal use” tests tomorrow.

1 Like

This is potentially a huge for boon for for standby time! Anyone try it yet? I would but I don’t have DP, waiting for their HDMI firmware.

1 Like

Hello to all
I am facing similar issues as some of you - the audio card is draining my battery during sleep.
I have installed FxSound and it is listed as main villan in the power drain report.
I have reached support of FxSound forum to make sure that it is not a seperate issue, but the response was, that it must be rather something beyond the FxSound after all.
FxSound forum entry
I have Windows 11 and I cant see the High Definition Audio Controller on my device manager.

Can anybody tell me what is the conclusion with this issue? Is there a solution?
Thank you

I fixed this recently on my machine by uninstalling the RealTek drivers and letting Windows install the default HDA controller/driver instead. Very happy with it. Go to Control Panel, under Audio, and remove the speaker device. Reboot. Windows should install the default driver instead. Try that and see if you notice better battery life on suspend/sleep.

BIOS 3.17 release notes say:

However after some testing it doesn’t look like anything has changed during suspend :slightly_frowning_face:

BIOS 3.09:

BIOS 3.17:

Using 1 HDMI, 2 USB-A, and 1 USB-C cards

1 Like

Hi everyone,
I’m running into a weird issue with Modern Standby (S0). There seems to be about a 95/5 split in behavior when in this one mode. This occurs primarily while plugged in although has happened while unplugged as well, and is independent of my Thunderbolt 3 eGPU.

Specs are i5, 2tb WD_BLACK SN750, 1x16gb.

In one case:

  • I tell my computer to enter modern standby (power user menu>shut down or sign out>Sleep, Windows key>power>Sleep, lid close, etc)
  • The fans increase to 50% speed
  • The display turns off (if connected to external monitor via HDMI card or eGPU, that turns off)
  • The power button stays illuminated
  • My USB peripherals (backlit keyboard etc) stay powered
  • remains like this until I initiate a wake (mouse, keyboard, touchpad, lid, etc)

In the other:

  • I tell my computer to enter modern standby (power user menu>shut down or sign out>Sleep, Windows key>power>Sleep, lid close, etc)
  • The power button begins ‘breathing’
  • My peripherals lose power (backlight for keyboard turns off)
  • The fans slowly ramp down over a minute and turn off
  • Remains like this until next wake event (mouse, keyboard, touchpad, lid, etc)

I would very much like to keep the second behavior while eliminating the first (my laptop backpack has no ventilation and will cook the laptop, the keyboard is bright if it’s connected, and the fans are mildly annoying). Does anyone have any suggestions? I have tried disabling Modern Standby via registry and going to S3, but this disconnects my eGPU meaning I’d have to replug it every time I resume from sleep. The system events for both behaviors are the same (interestingly, the first will not change powrcfg.exe /lastwake, and shows up in a sleepstudy as screen off but not sleep, and the second will increment lastwake and display a screen off and sleep in sleepstudy).

Any help is appreciated. Thanks!

1 Like

I’d try running this before sleep and noting any differences:

powercfg -requests

This will show apps/drivers that are causing the system to stay awake. If there’s an app showing up in the non-sleep state that doesn’t show up in the sleep state, it suggests that app is the culprit.

I’m approximating, but it’s faster than the speed that it normally stays at and quieter than full speed when I’m rendering video etc

Fan increase and light staying on is the 95, sorry it wasn’t clear

Requests says nothing as well, sadly. Before it would sometimes say the UsoWorker service was waiting (I had registry disabled windows update so maybe that was just spinning forever and preventing sleep but I’ve long since re-enabled windows update to try and troubleshoot this)

LTT made a video on YouTube describing a similar behavior.
It seems like that the machine cannot detect power-state changed while it is asleep, thus if you plug your machine in it will maintain “network connected” state and screw everything up

Need to verify but seems promising.

1 Like

I just saw that video yesterday, It’s my exact issue!

Unfortunate that it’s not a framework specific thing. What’s worse is S3 doesn’t play nice with my eGPU, and because S0 and S3 are mutually exclusive based on a registry key and a restart, I can’t create a service to swap between the two on power status change. I’ll just have to live with it until either windows or Intel changes something I guess.


Looks like this video from LTT might be relevant to the Framework laptop, but not just the FW, but all Windows laptops, as Xavier_Jiang mentions here:

Hopefully this shows how this isn’t just a Framework thing.

The irony? This problem is why I ditched Windows 10 on my FW. I went to Linux because there this modern standby garbage doesn’t exist. And here is the thing, even if modern standby worked flawlessly, I have a problem with me telling my computer to sleep, and it doing what it wants to do instead.

I get that the average computer user is clueless, but this is a precedent that should not be embraced.

Anwyay, I’m really happy to hear that FW implemented S3 in their 12th gen bios!!!


Can confirm it’s available in 11th gen as well through the PlatformAoAcOverride=0 registry hack and a reboot.


For me, resume from S3 takes longer (12-13s) than from hibernate (10s), defeating the purpose.

As seen from early in this thread, other laptops drain a fraction of the power in s0ix vs. Framework. There is still a lot of room for FW-specific improvement.

Oh yes! Suspend to RAM ftw

Even on the Thinkpad T14 you would think that “Linux sleep” will give me support for S3
Not true. But, at least after I press the power button, the machine will go to sleep. Provided that I do not plug/unplug anything (including power)

Well, all the diaplay adapter cards contain active circuitry, so they will drain some power.
And then come the fact that we have slots for RAM, which is more inefficient than direct routing to soldered chips.
It also does not bypass the fact that S0IC/IX is absolute horrific.

It also depend on device manufacturers, and my Thinkpad seem to have a feature called “auto-hibernate” which will put the device into hybernation after sleep(ing) for a certain amount of time or after a (system) specified amount of power is drained. It’s called “dozing off” or something. I saw a log saying that and was super-confused.

You might have to connect/disconnect it before/after you sleep your computer.
Really? Although it does make some sense, since S3 turns off the CPU (mostly), which probably also includes the onboard Thunderbolt controllers.

That’s precisely what I want to avoid, haha. What happens if I try to enter S3 with it connected is that it disconnects and I have to unplug+replug to reconnect it.

I’d copy my custom service to handle brightness on/off AC and create one to swap the sleep type on AC attach (I only ever use my egpu when charging), but you need a restart after the registry hack to change from modern standby to S3.

1 Like

I’m a bit confused by the S3 sleep behavior, why does it take this long? On my X200 it wakes within 5s or so! Would it be possible for this to be patched through bios?

Although the people who use S3 is probably very limited considering it’s a mod on Windows (unless Linux uses it by default, haven’t checked).

S3 on WIndows under the 11th gen mainboard didn’t take long to resume. However there weren’t any real power savings from it that I noticed, so I switched back to S0 but with network disconnected.


S3 is “suspend to RAM” which basically turns off the CPU but keep the memory alive.

S0 Low Power keeps the CPU in a “low powered state”, which, even in S0 dont consume that many power (as I am typing my Ryzen 5 4650U reports 2.5-3W of power consumption) in the first place.

So depending on optimizations, chipset and OS routines it might take a while. Not to mention how Windows 11 is vastly different (from Windows 10).