Windows 10 - Inconsistend wake behavior

Got my DIY edition a week ago and while I generally like the laptop I have noticed a very annoying issue; at least with mine. I turned off modern standby to see if the abysmal battery drain when the laptop is closed would be resolved (spoiler, it hasn’t). Now every time I open the lid it will randomly either wake up locked (expected behavior) or the screen will turn on for a second, then turn off and sit there with the power button lit up. The power button will eventually go into that breathing state when it’s asleep, if I press the power button at that point the laptop will wake up to the windows login screen and everything works. This is super annoying obviously since it takes a good 2 minutes to make the laptop useable. I tried updating to the 3.03 bios and the beta drivers from 08/30 but no joy :-/

I experienced the same. I honestly don’t believe Tiger Lake handles Sleep states like S3 very well. I just switched back to S0 and disabled connectivity. I also set my default lid close action on battery to hibernate, and this seemed to make a huge difference. Restoring from hibernation is incredibly fast, and has the added benefit of not draining the battery at all, regardless of how long it was left in hibernation.

The ideal goal is to get around 10+ hours of standby before hitting the 5% battery drain mark and S0 enters hibernation. As of right now we are seeing about 2.5 hours before 5% is hit. Some room for improvement for sure, but with how peppy hibernation is, not a real issue for me. Everything else on the Framework seems to be a home run.

While I haven’t exhaustively tested this, I do think that right now, standby time is better under Linux with deep sleep enabled.

1 Like

I agree that Tiger Lake still has a lot of things that need to be figured out. I fully expect that future BIOS and driver updates will improve battery life.

I initially installed PopOS on the laptop and ran it or a couple of days. The drain while the laptop was closed wasn’t much different than it is under S3 in Windows. I’ll try re-enabling S0 and disable connected standby and see if I get better results.

Edit: Re-enabled S0 but don’t see an option to disable the network when sleeping. Can someone point me to where I can do that? All the articles I’ve seen mention registry keys that don’t exist on 21H1 or options in the power settings or advanced power that also are not there.