High Battery Drain During Suspend (Windows edition)

@feesh which SKU do you have? Could you share the output of:

pnputil.exe" /enum-devices /class MEDIA /connected

run from an admin shell.

@Kieran_Levin I have the i7 DIY. pnputil output:

C:\Windows\system32>pnputil.exe /enum-devices /class MEDIA /connected
Microsoft PnP Utility

Instance ID:                BTHHFENUM\BthHFPAudio\8&2cc85896&1&97
Device Description:         LE-Bose QC35 II Hands-Free AG Audio
Class Name:                 MEDIA
Class GUID:                 {4d36e96c-e325-11ce-bfc1-08002be10318}
Manufacturer Name:          Microsoft
Status:                     Started
Driver Name:                microsoft_bluetooth_hfp.inf

Instance ID:                BTHENUM\{0000110b-0000-1000-8000-00805f9b34fb}_VID&0001009e_PID&4020\7&17e6baa8&0&2C41A183D5D0_C00000000
Device Description:         LE-Bose QC35 II Stereo
Class Name:                 MEDIA
Class GUID:                 {4d36e96c-e325-11ce-bfc1-08002be10318}
Manufacturer Name:          Microsoft
Status:                     Started
Driver Name:                microsoft_bluetooth_a2dp_src.inf

Instance ID:                INTELAUDIO\FUNC_01&VEN_10EC&DEV_0295&SUBSYS_F1110001&REV_1000\5&3298e61c&0&0001
Device Description:         Realtek(R) Audio
Class Name:                 MEDIA
Class GUID:                 {4d36e96c-e325-11ce-bfc1-08002be10318}
Manufacturer Name:          Realtek
Status:                     Started
Driver Name:                oem21.inf
Extension Driver Names:     oem20.inf

Instance ID:                INTELAUDIO\CTLR_DEV_A0C8&LINKTYPE_06&DEVTYPE_06&VEN_8086&DEV_AE50&SUBSYS_00000011&REV_0001\0601
Device Description:         Intel® Smart Sound Technology for USB Audio
Class Name:                 MEDIA
Class GUID:                 {4d36e96c-e325-11ce-bfc1-08002be10318}
Manufacturer Name:          Intel(R) Corporation
Status:                     Started
Driver Name:                oem61.inf

I suspect it was failing the check before because I was using the default Microsoft audio drivers.

In other news, looks like the audio controller drain is gone!

While ~3.2%/h is still a bit higher than I’d like, it is much better than before.

3 Likes

Thanks for helping us catch issues and resolve them before we roll the driver bundle out to a broader audience!

4 Likes

Thanks feesh and RandomUser for the idea. I did the same by editing the install.bat to including JUST the audio driver portion. As preparation for that, I used the original framework driver package to reinstall the realtek audio driver Framework provided. Then I ran the script.

When I run the

pnputil.exe /enum-devices /class MEDIA /connected

command I get info for the realtek audio and intel SST. Where as before I did all of that (but had already tried installing the updated driver package) I had just the Realtek audio driver showing up.

So something is definitely failing. When I reinstalled the Realtek driver, and then ran the driver update package, it still did not install the audio drivers. Modifying the install bat file was necessary.

I’m not sure if re-installing the Framework provided Realtek audio driver is necessary before installing the Intel SST driver. Might be something to clarify before officially releasing.

This IS an improvement from before. It was about ~1 hour before. BUT, it would be good if we got a bit more standby time for our 5% of battery life. Still hibernate is what I set my lid action to when on battery. Seems the best way to not loose any battery % for being unused.

I’m hoping that we get some more insight into what else is draining, as ~3% per hour is still way above my expectations. I’m used to <0.5% per hour on other laptops.

Random Googled solutions I’ve tried with no noticeable effect:

  • Disabling network connectivity during standby via Power Plan
  • Disabling Intel Management Engine device in Device Manager

Like @RandomUser, the only other red I’m seeing in SleepStudy is NoHwDrips.C10.Unknown. No idea what it means though.

Hibernate is fine but I prefer the instant wake from Modern Standby. Tried switching over to S3 sleep after seeing this but for me, waking from that takes about 30 seconds (much longer than waking from hibernate).

1 Like

My tiger lake spectre 13 lasts for 15 hours before draining 5% of battery. My latitude 7420 lasts 10 hours. In my 13 hour workday if I open my laptop four or five times over that span potentially 20-25% of my battery would be consumed just from it being asleep (or rather, in modern standby), wheras other tiger lake laptops demonstrate that you can achieve that same kind of workday only losing a few percent to modern standby. Clearly further optimization needs to be done.

EDIT: Decided to check my other laptop’s performance in modern standby instead of relying on memory. Here is my 2020 spectre x360 with an 1165g7, 8x2GB 4266mhz, 1TB SN550.

25 hours to drain 5% in modern standby.

4 Likes

I was curious about that, and honestly, that is the performance I was hoping for, otherwise modern standby makes very little sense.

I’m sure we will see some S0 refinements that improve the efficiency of the process.

1 Like

I also get to the 5% threshold in about 2.5 hours where standby switches over to hibernate. I’m hoping there would be another driver update in the works

2 Likes

Interesting. Maybe it’s the HDMI card power draw seen by others? Can you try with all but HDMI attached?

So @RadomUser did you see what kind of sleep battery drain you were getting with all of the cards out?

If we can get the Framework to sip power in S0 before hibernation such that we can see 8-12 hours before 5% battery drain that is going to be pretty awesome!

For the record I have 2 USB A, 1 USB C, and 1 250GB SSD.

Just to confirm, this is in sleep/modern standby?

USB-C & USB-A cards are just pass through… No logic is in them.

HDMI & Display Port are adapters, in Windows you can actually see them showing up as that is the USB safe to remove icon. They need power Scotty.

I suspect there is a “do you want power now” type of interrogation done in short busts even when sleeping by NoHwDrips

So looks like the HDMI card is drawing ~0.5Wh during standby. That’s quite a lot.
Sorry misread. So it must be the USB-C and/or -A cards draining that 0.5Wh?

USB-A and USB-C are indeed passive, so they shouldn’t be impacting standby. If you can isolate it to one of those cards being plugged in though, we would be very interested in exploring why that would be.

@RandomUser are those results repeatable? If you re-run with the same configuration of cards does it result in the same high vs low behavior? I am wondering if something else is going in or out of a standby state in different runs.

One thing I’m noticing is that if the laptop is plugged in, charging or full, and you suspend, the device stays warm. I mean if you leave it like this for two days, you’ll come back to it, and it’ll still be warm, like it isn’t even really sleeping.

I don’t know, S0 doesn’t seem to be all that great. I would REALLY prefer the old S3 and hibernation combo I think. When I tried enabling them though, the laptop did not seem to like it much.

Does Tiger Lake just not support S3?

1 Like

so the official answer there is No. S3 is not supported under Tiger Lake, and and S0 is what we have to work with.

@RandomUser Had the same idea last night and pulled out my Storage (250gb) and USB-A module out (I already leave my HDMI un attached) This morning only lost 5% over the entire night. Pulling out my 1 USB-C and seeing what it does today
image