High Battery Drain During Suspend (Windows edition)

So I did a clean install of Windows 10 21H1 on a 512GB AData SX8200 Pro (hardware revision unknown) then installed the Framework driver package (2021_07_08) and the latest ADK.

Running SleepStudy resulted in a 5% drop in battery after an hour with the same Realtek HD Audio as the top offender. Switching to the Microsoft audio driver removed the HD Audio as an offender.

Weirdly though, I’m still seeing a 5% drop per hour even though the top offenders list looks all green now. It’s consistent too across multiple tries.

I think maybe the culprit is the SX8200 Pro from what I can glean from the WPA trace analysis. It spends almost the entire sleep cycle at D0 (normal power state) instead of dropping to a low power state. But maybe that’s normal, I don’t have another SSD to try a Windows install on.


Adding some more datapoints here from my own anecdotal experience.

  • Overnight, my laptop (unplugged, lid closed) was presumably in sleep mode. Upon waking, I discovered the bottom of the laptop was quite warm and the battery had completely discharged. powercfg /SleepStudy confirmed that the laptop was active for 6.5 hours and discharged 96%. I haven’t had a chance to dig into this deeper yet.
  • powercfg /a reports the same sleep states for me as @feesh mentioned here. I also have the Framework-provided drivers installed.
  • At times, I’ve noticed that the laptop wakes from sleep slowly. It could take a minute of “pulsing power button” activity before the screen awakens.
  • At other times, I’ve noticed some applications (Chrome) seemingly being responsive, but failing to render / refresh for at least 30s. This only happens after a wake from sleep.

P.S. I’m happy to open a separate thread, but it feels appropriate to group these here.


@obfuscurity If SleepStudy says active then it didn’t properly enter standby mode. Double check your lid-close action settings (Start > type “lid” > Change what closing the lid does)

Or put it to sleep using (Start > power icon > Sleep) to be sure you’re putting it to sleep.

@feesh Right, I can see that it didn’t enter standby. As I mentioned, I haven’t had a chance to investigate further. All of my lid settings remain set to sleep.

Is there a way to check that the lid close sensor is activated? Do the side LED’s indicate that it is going to sleep? Or back to active?

With my old MSI I can at least peak into the closing lid and see if the screen is turning off… And it has external LED’s for power indicator.

FYI another user reporting sleep issues with the Realtek driver


This is fantastic seeing all the responses directly from the team, keep up the good work fellas!


So I wanted to uninstall the Realtek driver, but I can’t seem to get it done. Every time I uninstall and reboot, Windows is reinstalling the Realtek driver instead of the Windows generic audio driver.

For now I’m having to hibernate always, as the device is basically on while in standby, and I don’t want to risk overheating in the laptop bag. The good thing while we wait for a solution? Hibernation is incredibly fast. I’m thinking about remapping the lid close action to trigger hibernation for the meantime.


What I did was go to Device Manager > Device Properties > Driver > Update Driver > Let me pick from a list…

Then select the Microsoft driver from there. That said, hibernation on Windows works well so considering the buggy nature of Modern Standby it probably makes more sense to use that.

1 Like

Ok, I was literally doing the same but instead of update, uninstall. I’ll try that, and see if there is an improvement. I’d like to use the driver intended for the hardware just to make sure we are getting the performance out of the device, but sound design isn’t something I’m trying to accomplish on the laptop, and so I think the windows generic will work in the meantime.

Regarding the modern standby: I think it is brilliant honestly. If it really works the way it was detailed here. Regular standby with immediate resume until the battery has lost 5% and then hibernation. With how fast the Framework hibernates and resumes from hibernate, I think it is perfect. I do wish we could have the lid open action trigger a power on, similar to a thinkpad. All in good time I imagine. I love this thing.

1 Like

I’d prefer to have S3, but Intel removed S3 from Tiger Lake. The Modern Standby to hibernate behavior is nice in theory, but I’d feel uncomfortable using it unless it’s demonstrated to be rock solid reliable so the laptop doesn’t turn on while in a bag.

Not a knock against the Framework team though, even Dell and Lenovo seem to be struggling with getting Modern Standby working 100% perfectly on their 11th gen laptops.

1 Like

@2disbetter Did you uninstall the Realtek apps? I uninstalled both of them, rebooted, and it’s been using the Microsoft audio driver ever since.

I’ll start a new thread for this, but I’m running into an issue (also possibly related to modern standby) where there the clock speed gets stuck at .39Ghz. It seems like disabling modern standby fixed it (edit: nevermind, didn’t fix it), though rebooting while plugged in might also have done it. Apparently this is a common win10 issue, e.g: laptop - Infamous 0.39 GHz in Windows 10 issue has no fixes? - Super User

Yes initially I uninstalled all three of them. (mic, speakers, and sound card) When I restarted it reinstalled the Realtek drivers during log in.

@2disbetter in my experience to fix the sleep draining, I only need to uninstall the driver under Sound, video and game controllers > Realtek(R) Audio > Uninstall Device (making sure to check the Delete the driver software ... checkbox).

The devices will still be named Realtek(R) Audio but if you inspect the driver files (Properties > Driver > Driver Details) there will be no Realtek drivers (RTAIODAT.DAT and RTKVHD64.sys)


I’ll give that a whirl. I didn’t bother to inspect the driver, but in retrospect that makes a lot of sense.

Edit: Seems to have fixed modern standby for me. :+1:

Looking forward to updated drivers though.

So while sleep and hibernation components seem to be working as intended under modern standby, I’m finding that even though the audio driver is not the culprit, that I’m still loosing about 5% per hour. It would be great for the computer to stay in standby versus hibernation for at least 2-4 hours. Right now I’m getting about an hour of standby before the 5% mark is reached and hibernation is entered. This means every time I suspend the laptop normally, I’m basically going to loose 5%. While the computer resumes from hibernation very quickly, it is annoying to have to push the power button almost every time I resume using the laptop.

Also, I read that modern standby maintains the network connectivity. Is it possible to disable that? I would prefer it if standby behaved the way S3 does. The only time I want the computer doing anything is when I am actively using it (ie: the lid is open).

1 Like

What SSD do you have?

I ran into the same with an AData SX8200 Pro that wouldn’t seem to go to a low-power state. With a Sabrent Rocket 4 Plus and the HDMI expansion card removed the longest I got before it hibernated was 2.5 hours. This testing was done without being connected to a network too.

I believe it is a WD Black 1TB NVME that I bought from Framework directly.

Part of me thinks that not understanding the modern standby conditions could be the issue here. IE: what software could be interfering and not responding to SO properly. I suspect my browser might be able to perform tasks in the background, and for various chat web clients, this could mean they are trying to maintain connects through S0. I’m going to check if that is the issue, and I’ll report back.

“connected standby - network connected” can be switched to “connected standby - network disconnected” via gpedit or regedit.

…not sure that they’re called exactly that.