Intel AX210, Windows 11 not seeing 6GHz band

I just acquired a Netgear 6E router and was eager to experience all the mind-blowing, white-knuckle wireless performance that it promises on the box.

Unfortunately, I’m unable to see the 6GHz band with the AX210 in the Framework. 2.4GHz and 5GHz are fine.

It wasn’t working with standard Windows 11 builds, so I moved to the Insider program, to no avail. I’m now on 22.100.x of the Intel drivers (the third version since I got the router) and still no luck. This afternoon I tried re-seating the Intel card just in case something was loose, but that had no effect, either. All of the Registry values appear to be in order as well.

Anyone experiencing 6GHz visibility issues with their Framework/AX210/Windows 11 too? Any additional troubleshooting ideas?

1 Like

If you’re feeling adventurous you can follow the steps in this post. I did so a while back before I upgraded to windows 11 and it worked. I believe that it still was after the win11 upgrade, but I usually am not booted to windows.

Hey, sorry to bring this thread back to life. I’m seeing issues with this as well. My Frameworks (we have 2) and a network capable of WiFi 6e (6Ghz). Following the instructions posted above, using the drivers in that article, allows the Frameworks to connect via 6Ghz band exactly once. Only the first time after the drivers are installed. Reboots after that, it drops back to the 5Ghz band. Any ideas on that?

Windows 11

I have to roll back to the AX210 driver if I want to connect to the 6GHz band. Anything after that, up to and including the current driver, results in me only being able to see the 5GHz band.

As for the “connect once” issue, I’m not seeing that exact issue with the working driver and my Netgear RAXE router. But I do notice that the driver tends to prefer the 5GHz band, even when I’ve got a strong 6GHz signal. It will regularly drop back to 5GHz, and I’ll have to manually reassociate with the 6GHz.

For the time being, though, I’ve said eff it to the 6GHz and am on the driver. Am planning on reverting to my Asus non-6E mesh network anyway, so I won’t be able to make use the 6GHz band even if they ever do get it working reliably.

I do run a mesh 6e network, it prefers to leave the ssid the same for all bands for roaming purpose. So I can’t specifically tell it to connect via 6Ghz band. It definitely connects in the 6Ghz the first time. Then after it does look like it prefers the 5Ghz, even though 6Ghz is available. Even if you go into the advanced driver settings and set it to prefer the 6Ghz, it doesn’t. It’s definitely not a Framework specific issue. Installing the same model of WiFi card on another laptop acts the same way. It’s gotta be drivers/firmware on Intel’s side.

I’ve pretty much said the same, eff it to 6Ghz and let it do what it wants. I get fantastic connection anyway. And maybe that’s the point, maybe it’s doing some form of quality check or something and finds the 5Ghz is better.

Anybody got this working without downgrading driver or have any news on when are we going to have a working wifi driver ?

The funny part is when you go and check device manager , the wifi card let you choose many options related to the 6ghz but then I can’t see a single wifi 6e network that I’m using with my other devices…

Unfortunately, this looks like an issue only Intel can resolve, and based on the few related threads I’ve been able to find on their support forums, they have zero urgency to do so. Maybe there hasn’t been a critical mass of complaints because the already small pool of users with 6E routers is just suffering in silence with fingers crossed that the next version will be the miracle cure. Whatever the case, until one of us can identify a competent Intel engineer and hold their family hostage, it looks like the 6GHz band is going to remain invisible for some of us unless we’re willing to remain on the outdated .45 version.

FWIW, I just put together my Framework laptop today and am giving Fedora 35 a try, and it’s no better over in Linux land. I strangely DID see my separate 6E network during the initial setup process and tried to connect, but the laptop choked on it and I had to restart to get things running again. Same as those of using using Win11 on it, the 2.4/5 GHz bands are fine and performance is very good. But I have a 6E mesh network for my VR headset, and was excited to see that the Framework would be my first PC/laptop device that also has 6E…and no luck. Anyone on the Framework team aware of this issue? Happy to do some experimenting and pulling data if we can be of any help…

So I’ve been researching info on the AX210 in general the past 24 hours, and I’m pretty convinced that Intel and Framework generally just have not done much testing with actual 6 GHz connections using this module. From all of your posts here it sounds like Windows 10 can work correctly with a very specific driver, but I’ve yet to find anyone who has been able to get a functional, reliable 6 GHz connection with the AX210 on Windows 11 OR pretty much any Linux distribution. I’m really enjoying Fedora on the Framework for now and my second storage module isn’t showing up until later next week, but once I get it I’ll see if I get a similar experience with Windows 11.

There is the secondary issue I’m finding from Intel reps reminding users that if 6 GHz is not approved in your geographic region, the manufacturers are REQUIRED to not allow that band to work. I believe everything I had configured is set up for the United States (I’m in California) so that shouldn’t be my issue…but I don’t have any way at the moment to confirm something isn’t being tripped up there. If anyone finds additional info I’d love to hear it. I’m just glad the Wifi 6 bands are working well, but having 6E and not being able to use it is kind of driving me nuts. :slight_smile:

Which one is that ?
Is it the mentioned above ?

I almost lost my sanity a couple nights back, trying to connect to the 6Ghz band on my 6E router, only to assume I had to switch to W11 to finally get it to work.

From what I can read, it could have actually made things worst ?!

I believe that’s the one I read worked for several others, but I’ve since lost the link and gave up on it for now. Windows 10 and Fedora 35 are both otherwise working great and I’m getting faster wifi speeds than I’ve even seen on a laptop. Hopefully we’ll be able to unlock the advertised 6 GHz functionality in time and I’m going to keep an eye out for updates.

Ok, got 6e to work on an AX210 after downloading the drivers today. I have an Asus ROG Crosshair VIII Extreme motherboard with the radios onboard. Updated to the latest driver from the Intel site and it now works. Have two laptops, one on W10 and one on W11, that I cannot get to work with the latest Killer suite.

1 Like

I am still having issues with this. I have an ASUS ROG AXE11000 router and a AX 210 chip that I just put in my Alienware. The modem works just fine other than not seeing the 6hz channel. I quadruple checked the drivers, the router to ensure the channel is indeed on, and I am at a complete loss of why I am not picking up the channel at all. I connect to the 5hz and 2.5hz just fine and way faster even the the qulacomm nonsense that came with the system.

Any help would be greatly appreciated.

I’m also having a problem connecting to 6Ghz Wifi networks in Windows 11 on my 11th gen i5 Framework with the Intel AX210 card.
My Wifi 6E AP is a Ubiquiti U6-Enterprise.

I have an older Dell XPS 9350 that got a fresh install of Windows 11. It has the same Intel AX210 card (purchased from and it immediately sees the 6Ghz and works as expected.
I used the same USB stick to wipe and reinstall Win11 on the Framework, and no 6Ghz. Only 2.4 or 5Ghz.
BIOS is v3.10.

I know the hardware is good – If I boot Ubuntu (pre 5.16 kernel), the Framework sees 6Ghz and works.

This sure does seem like something missing in the Framework ACPI. Maybe some region information? Since 6Ghz is only allowed in a few geographic regions.
I tried resetting the BIOS to Optimal Settings, but that didn’t seem to make a difference.

The bad news: Intel is somewhere around a year behind in updating the firmware-controlled lists of what countries allow what channels in 6ghz. There is no way to disable, circumvent, or update that inbuilt registry that I have found. They have literally crippled their devices on linux out of sheer laziness.

The good news: the AX210 is not the only option anymore. I am ripping out all intel cards from all of my machines and going to the MT7921K.

TP-Link AXE5400 - Archer AXE75 WIFI 6E Router

I found my problem to be in router configurations!

  1. Make sure you have latest Intel driver installed (ie. )

  2. Make sure SSID is not Hidden under wireless 6ghz settings and shows up in WIFI internet list in task bar, might have to shut WIFI off and on a few times or reboot system till yours show up!

  3. Make sure to uncheck PSC box under wireless 6ghz settings, this reserves only higher channels for connection!

Should connect immediately with WPA3 encryption!