Is anyone dual booting with Windows?

I’d like to dual boot Windows and Kubuntu using a single SSD, and I was wondering if anyone has tried to do this. Did you run into any issues or oddities?

I don’t have my Framework 16 yet but in my experience, dual booting Windows and Linux is not very problematic.

I don’t have windows on my GRUB menu, but rather just select the windows boot drive from the boot selector that is built in to the laptop. I don’t use Linux a lot which is why I didn’t mess with the GRUB boot selector, but there are probably some guide online on how to do that.

One thing I would recommend is to install Windows 11 first because then the installer on the live USB should recognize that there is already a windows install and you can just choose the setting to install alongside windows (This is from Linux Mint idk about Kubuntu, but it should be mostly the same.)

I did experience Windows overwriting the default boot entry, but found a workaround for that:

  1. Install Windows
  2. Boot into the Live System of your linux distro prior installation
  3. Mount the EFI partition
  4. move all files inside EFI/Boot to EFI/Microsoft
  5. Install Linux
  6. Choose between Windows and Linux using Grub

P.S.: You might want to increase the EFI partition size before installing Linux, because Windows automatically creates one having just 100MB, especially when you plan to install Fedora.

1 Like

I should have mentioned that I’m fairly experienced using *nix. I’ve used some type of “unix like” OS every day since the mid 90s, and have been using Kubuntu as the only OS on my 11th gen FW13, and the two systems I had before that. I haven’t tried dual booting in more than 10 years, so I started this thread to see what the current gotchas are. Especially any quirks specific to the FW16.

And as I said, I’m planning on only using one drive in my FW16 so I can’t choose the OS to run by selecting a boot drive using UEFI.

You definitely can! The firmware boot menu operates on “boot entries” rather than on entire drives. When you install Linux, it should create a new boot entry in NVRAM that will show up in your boot order list.

1 Like

I wanted to setup dual boot after I had some OOM issues with some non-steam games in proton that have a launcher.
Since it was only planned as a gaming fallback, I ordered the 1GB SSD expansion card, which by itself works perfectly.

As a precaution, I disconnect every drive and only have the drive that Windows will be installed on connected, for decades now.
But turns out that Windows Setup is still a total PoS and does not let me install onto an USB drive: First it complained about the file system (came formatted with exFAT) and then just about being connected via USB.
Ultimately, I gave up on Windows and “just” fixed the OOM issues with proton (turned out that the games needed >4GB of RAM but the launcher lead to Proton starting in 32bit mode)

You may need to fix the Linux vm.max_map_count as described here: Elasticsearch Vm.max_map_count: Overview & Optimization

Most distributions are using “1048576”: Changes/IncreaseVmMaxMapCount - Fedora Project Wiki

Looks like Arch already has increased that count: Arch Linux - News: Increasing the default vm.max_map_count value

Hi, i used rufus to create a Windows 11 installation on the 250g usb storage module, i presume that should work fine for any usb dongle.
See here:

My only gotcha with both intel and amd fw13 was the way they handle the cmos clock. Windows wants your hardware clock in local time, most linux distro want it to be utc. You may find the time on your pc is wrong every time you switch. The fix is pretty simple, just tell one of them to do it like the other depending on your preference.

I was tripple booting windows 10, win11, and xubuntu without any trouble off of one disk.

I don’t think that’s a fw13 issue, pc’s have only a single cmos clock, and it’s the os that chooses what time to put in there, hence you need to address the issue in the os (either windows or linux).

Yes, sorry if that wasn’t clear. The timezone vs cmos clock difference would be an issue on any system, not specific to a framework laptop.

Some details here: [Solved] Wrong Time in Windows 10 After Dual Boot With Linux

TL;DR - Run this command on the linux system

timedatectl set-local-rtc 1

Hey, I got my FW16 in batch 9. I’m running ubuntu and Windows 11 here. No issues so far, my only suggestion is to install windows then install ubuntu as installing ubuntu first can lead to windows overwriting the grub boot menu and booting straight into windows without the option to select windows 11 or ubuntu.