Issue with Evoluent VerticalMouse 4

I’m trying to use the Evoluent VerticalMouse 4 Small with my Framework laptop, but when I plug it into the USB A port it keep on disconnecting and reconnecting about every 4 seconds, making the mouse very difficult to use.

This was an issue when I first installed it, and I’ve since installed both the Framework driver pack and the specific drivers for this Evoluent mouse, but that did not fix the issue. This mouse works fine with my other laptops, so I don’t think it’s a mouse hardware issue.

On the other hand, I have a cheap Logitech mouse that works fine with my Framework laptop, and it doesn’t seem to matter what port I plug into, so it doesn’t seem to be an obvious hardware issue with the Framework laptop either.

I am running Windows 10.0.19043. Let me know if there are any troubleshooting steps I should try.


Did you every find a solution? I am having the exact same issue with an Evoluent C on my Framework on Windows 11. All drivers up to date.

No fixes or workarounds yet, unfortunately. Glad it’s not just me, though.

I am not sure if this is related, but it is certainly fishy. Around the same time that I have the Mouse plugged in, I get message spam in Event Viewer.

These two keep appearing ad nauseam:
“The driver entered RTD3. All the connected devices will be removed from driver’s internal state, so it is expected that DeviceDisconnected events will happen.”
“Driver exit RTD3. All the connected devices will now cause DeviceConnected events.”

I believe this has to do with power management, so I tried disable power savings on each and every USB and USB-related device in Device Manager. I also tried this while plugged in, and while only on battery. No dice. Issue still persists.

Issue was due to this. Looks like 2 of my ports are ‘bad’. I will have to fix this ASAP. I just typically used the other 2 slots for USB-C charging and HDMI for a secondary monitor. Once I swapped one of those out, it worked.