Issues with hdmi port cards

We have a new Framework laptop with 12th gen mb. Am very happy with this machine in general but we are having one issue with the hdmi port cards which so far tech support has not been able to help with - with a standard Asus 27 inch monitor, they work intermittently or not at all; at best, if I do a cold boot, it will work, but then a soft-reboot or just letting the machine sit for a while results in a black screen. All 4 ports on the motherboard are confirmed working (they work fine with usb-c or usb-a cards, charging is fine. All power saving in both the monitor and OS are disabled. Am running the latest intel video driver as per Framework tech support’s suggestion. Driver pack and latest BIOS are installed. Cards are inserted correctly and fully seated. When I plug in a Dell or any of various 3rd-party usb-c hubs with HDMI, everything works correctly. So - not a disastrous situation as there are easy-enough workarounds, but something is not right. I should add that the monitor (Asus v279HAL) works fine with all of the 8-9 other machines we have here, as it does with the Framework via any hdmi connection other than the framework hdmi card. Fn+F8 or Fn+f9 do nothing. Has anyone else experienced this? In case I didn’t mention it above, all 4 bays work fine with any USB cards, so there is no reason to think I have a defective port on the mb, and I get the same results with both hdmi port cards in any of the bays/slots.

I should add that yes, we have switched the cable out several times. :slight_smile:

I haven’t experienced this with my HDMI card (11th gen). Assuming the monitor doesn’t work with the HDMI card plugged into any of the 4 ports you may have a defective HDMI card. The only way to test this is to try another device.

Another option is that the HDMI input option on the monitor isn’t automatically switching over to that input once it’s plugged in. I’ve seen some monitors that need the cable plugged in first and some after the input has been selected.

You could also try installing the latest drivers directly from Intel. If there is an unknown error then that may solve this issue.

I have started facing similar issues. I have 12 gen laptop with all up to date. When my pc goes to sleep it does not detect the external monitor. Dosconnecting cable is not working, only thing that works is taking out the HDMI card and put it back. I don’t want to do that every time my pc goes to sleep. @Ruth_Levi have you sorted that issue?

1 Like

Ultionis, I manually verify the input selection on the monitor each time - it is correct. And I have two hdmi cards both of which behave exactly the same way. Adam, no, have not sorted the issue so far, am waiting to hear from the Framework support people. They have offered to send me a third hdmi card, but unless they know that they have had a bad batch or have made an engineering change I am not sure that there is much chance it will make a difference. That said, I am happy to try that if they think it’s worthwhile.

@Ruth_Levi Do you have any other computers with Thunderbolt ports that you could try the HDMI expansion card with? I wonder if there could be an issue with your Framework mainboard, and testing if the card works with a different computer could be a good way to investigate that.

Azure, I do not, but there is no sign whatsoever of problems with the mainboard or the usb ports on it when used with any other cards.

PS, I I can try sticking the port cards into USB-c ports on other machines though.

It couldn’t hurt, but you are correct, it would be weird if the expansion cards didn’t work when the dongles did, just thought I’d try to offer another idea to try… this is quite the weird issue.

Azure, agreed. They are sending me two replacement cards, we will see what happens.

1 Like

I have switched port, that I am using. Now it is working, but we will see for how long

So… as an FYI for anyone having a similar issue, I just tried a no-name USB-C to HDMI cable from Amazon - worked fine. Unfortunately the user whose computer this is will be gone for about a week starting Sunday, but I am hoping that the new HDMI cards that Framework is sending will arrive before she leaves so I can test them. Bottom line, it is indeed a strange and somewhat annoying problem, but easy enough to work around.

That’s what I use. When I was speccing up my laptop I remembered I had such a cable and decided to just get USB A and C modules. It works fine, not sure why more haven’t taken this simple route really.

Anyway hope the new modules work out for everyone.

1 Like

Jason, only reason is that I wanted to eliminate one possible extra connection and source of problems for this user… it is definitely not a big deal though as we do have extra hubs/cables laying around, and now that I know that a usb-c to hdmi cable works fine with the Framework USB ports I will keep one or two of those here too.

1 Like

Update: It is clear at this point that the Framework HDMI cards do not work with an Asus VA279HAL monitor. Have tried four - one that we ordered with the laptop, a second that we ordered because the first one didn’t work, and two more that Framework sent me. I have asked Framework to refund the cost of the two that we purchased and send a call tag for all four.

To be clear: The monitor works fine with other computers, we have tried different cables, and there is NO sign that this issue is related to any of the ports on the MB, all of which are working just fine with usb cards. Also, all the usb-c hubs with HDMI that I have tried work, as do usb-c to hdmi adaptors/cables. So: not at all a disaster, we are just back to doing what we had to do with other laptops, using an external adaptor to connect to HDMI.

1 Like

Have you tried the usb card on another PC ?

Not sure what the point of that would be? The usb cards all work fine.

Well it happened again. I had to switch ports again to make it work. Should I contact the Framework support at this point?

Yes, you should.

I might as well give an update to my original post. Framework has refunded the price of the two hdmi cards we purchased after they were unable to offer any suggestions to get them to work in our setup. So we are using the gen 12 laptop now with a dell hub that has an HDMI port, and which works fine with the laptop and all the monitors we have tried it with so far. TL;DR - this was not a big issue, but I would have liked an onboard HDMI port that worked, and hope that at some point they will figure out why their current builds of these don’t handshake with all monitors.