Iwctl does not find any wifi networks (Arch, 5.15.12)

I am trying to install Arch on the DIY framework laptop. I am in the Linux environment booted from a USB drive. rfkill shows that wlan0 is unblocked. I run iwctl station wlan0 scan and I see that it is scanning for a few moments, then I run iwctl station wlan0 get-networks and it finds no networks (though my nearby phone shows many). How might I proceed?

Kernel 5.15.12
iwctl 1.20

I’m using kernel 5.13, but have a similar issue when I attempt to upgrade to 5.15. I’m using Manjaro, and can’t enable wifi at all. rfkill shows wlan0 unblocked.

It turns out I hadn’t attached the antenna to the wifi module while assembling my laptop, and that’s why the wifi module appeared to be working but not detecting any networks!


I’ve made fun of myself multiple time for this reason: you can’t possibly imagine how many times I’ve spent hours to debug similar issues, only to find out that I didn’t reattach the antenna correctly! The worst part is that, most of the times, it was on other people’s laptop… Welcome to this club, and the only thing to do is have a laugh at this and feel good because it was not a real issue after all (not to mention learning from the experience)