Network capabilities (likely attennas) stopped working

I set up a Framework Laptop (DIY edition) I bought two weeks ago. However, after shutting it down and charging it today, the network card (Intel AX210) was no longer detected.

Looking into the logs, the network card was detected my the operating system, but at some point it failed and the operating system could no longer use it.

I used the network card on another laptop and it worked fine. When I used another network card with my Framework laptop, it was still not detected. When I booted another operating system from a USB drive on my Framework laptop, the network card still failed to be detected. This makes it seem to me that it’s an issue with the network antennas themselves.

For more information, I run Arch Linux with the 5.15.13 kernel. The kernel logs are as follows:

> sudo dmesg | grep iwl
[    2.160085] iwlwifi 0000:aa:00.0: enabling device (0000 -> 0002)
[    2.171084] iwlwifi 0000:aa:00.0: api flags index 2 larger than supported by driver
[    2.171124] iwlwifi 0000:aa:00.0: TLV_FW_FSEQ_VERSION: FSEQ Version:
[    2.171700] iwlwifi 0000:aa:00.0: loaded firmware version 66.55c64978.0 ty-a0-gf-a0-66.ucode op_mode iwlmvm
[    2.379004] iwlwifi 0000:aa:00.0: Detected Intel(R) Wi-Fi 6 AX210 160MHz, REV=0x420
[    2.556317] iwlwifi 0000:aa:00.0: loaded PNVM version 0x4b50f925
[    2.572128] iwlwifi 0000:aa:00.0: Detected RF GF, rfid=0x10d000
[    2.642672] iwlwifi 0000:aa:00.0: base HW address: c4:bd:e5:52:0f:b2
[    2.660701] iwlwifi 0000:aa:00.0 wlp170s0: renamed from wlan0

lspci also lists the network card as a network controller.

Is there anything else I can do to troubleshoot this? Or do I need to return the front cover/buy a new one? Any help here will be appreciated.

Could you check if this occurs on Fedora 35 or Ubuntu 21.10? If the same issue is present, please submit a support ticket: Framework | Support

I actually solved the issue. Apparently RF-kill enabled itself at one point and was repeatedly disabling the device once it was recognized. I’m not sure why it happens, but I can just run sudo rfkill unblock all to fix it. Sorry for wasting any time.

1 Like