Kernel panics when AX210 is attached

The AX210 has been causing kernel panics when NetworkManager is enabled. Got my DIY edition a few days ago, this has been an issue for every distro I’ve tried (Arch, EndeavourOS, and Fedora) with the Framework. I was able to finally install Arch by physically detaching the wireless card and using internet over a USB tether from my phone. Right now, I have the card detached in BIOS. My kernel version is 5.16.12.

Is this an indicator of a hardware issue or some kind of firmware bug? I do not have any other network services other than NetworkManager running concurrently that can cause a kernel panic – the system works fine while tethered.

I’d recommend trying an earlier version of 5.16 and/or if 5.17 fixes it.

I’ve tried multiple old kernels and firmware packages, none have worked. I’ve been in touch with Framework Support to try and get a replacement AX210.

When I have the card attached, journalctl often doesn’t even show iwlwifi being loaded. It’ll just kernel panic.

Yeah, definitely sounds like a faulty card at that point.