AX210 not showing up on Mint 20.2

Just got my DIY Framework today and have been happy with it so far except for the AX210 WiFi not seeing to be working. I’ve upgraded the kernel up to 5.11.0-41 but the AX210 isn’t showing up in ifconfig at all. Stuck using a crappy USB WiFi dongle.
The module is installed and both u.fl connectors are seated. I even pulled it back out and reseated it to make sure the connection was good with no luck.
Any suggestions on where to start with troubleshooting?

If you run lspci, do you see something like this?

aa:00.0 Network controller: Intel Corporation Wi-Fi 6 AX210/AX211/AX411 160MHz (rev 1a)

If you do, the issue is firmware or drivers. If you don’t, the issue is something physical with the hardware (either it’s not properly seated in the slot or the card is dead).

Are you using the Edge iso or regular? Edge iso is for newer hardware and has a newer kernel : Linux Mint 20.2 "Uma" - Linux Mint

@Chiraag_Nataraj : Thanks for the tip, I’m seeing a bunch of Intel devices on the PCI bus but nothing that resembles an AX210 or WiFi adapter, just USB, RAM controllers, etc. The device is definitely seated properly in the slot, so I might have just gotten a bum AX210. Unfortunately, I don’t have any other computers with a spare M2 slots to test that theory. I might just shell out for another WiFi adapter.

@GFOM : Just the regular 20.2 Mate ISO. (not a huge fan of Cinnamon) I tried two different 5.11 kernels, with no luck.

Hmmm, that’s not a good sign :confused: Even if the terminals weren’t properly connected or whatever, as long as the card is seated properly in the slot, I believe it should show up in lspci (hell, even if there aren’t any proper drivers, it should still show up afaik). Sounds like a hardware issue from what I can tell. I’d definitely start a support ticket with @FrameworkSupport since you should at least get some money back if the card is actually non-functional (whether or not you decide to go with another card from them).

A quick followup. I went ahead and ordered an Intel 9560 to troubleshoot the hardware. It worked fine as soon as it was installed. The issue looks to be a DOA AX210. Working with the support team to have a new one shipped out.