Keyboard not working

Today my keyboard has stoped working. I didn’t bring my tool with me on travel so I haven’t opened it to check the connector but the track pad is working. Any other ideas besides RMA?

Could you file a ticket with the Support team: Framework | Support

Could you also check if the keyboard works in BIOS? (e.g. can you reach BIOS when booting by tapping F2 or F12).

I was not working in the grub menu. I then gave up for a day and then tried latter and it has returned. I am not sure if I will keep it. I am pretty unhappy with the instability and a few other things. I am going to hold off a few more days on the RMA. Maybe try another distro and see if it helps. The trackpad is almost unusable. Having been using Ubuntu and Fedora on Thinkpads for 10 years I did know how bad the Linux trackpad space was. I have no idea what happened with the keyboard but I could only use the onscreen keyboard and had no control at the grub menu. If it occurs again I will try to get into bio with and extranal device.

I found this thread because my keyboard was completely not responsive today. Not at first, but was was working on it for a couple hours. Your comment about it working again later led me to notice it was running hot, Like you the track pad was fine. I attached an external keyboard also worked fine.

I shut it down and let it cool and it is working again. It was on a hard surface so it was not a case of the air flow being blocked.

It hasn’t reoccured for me since? Who knows. Lots of updates in software and at least one rev of firmware. But I also haven’t been using the keyboard much.

Yes. I mean I still really like it and Windows 11 is very well behaved. But I hope that Linux will settle down and I can return to it as my daily.

I am also running Linux (Pop OS) on the Framework (13, 11th gen) and also had issues with the keyboard not working recently - but now I realized it was caused by the magnetic cable organizer under the desk!

1 Like