Keyboard stopped working

I just got my DIY laptop this Monday. Installed components, booted up, installed Fedora (36 beta) and used it for two days.

Fast forward to today. Wanted to demo the guts to a friend. Opened the top cover while the machine was running. Risky, but I was trying to be careful. Then I put the cover back on and tried using the laptop again.

But the keyboard stopped working. The touchpad, power button, fingerprint reader and even the keyboard backlight still work fine. I grabbed an external keyboard, powered it off, checked the touchpad cable. My machine is batch 10, so it had the adhesive to prevent the common issue, but I re-seated that end of the cable anyway. I also re-seated all other relevant connectors, including this one. I also tried a full mainboard reset but that did not make a difference.

(It did turn off the keyboard backlight, but that was working before the reset. The backlight is probably still fine but I have no way of enabling it without the internal keyboard. My thinkpad has /sys/class/leds/tpacpi::kbd_backlight/ but nothing equivalent on the framework… yet. With the EC firmware being opensource this could be a nice future PR. But this is a silly tangent if I don’t have a working keyboard first.)

So, I may have done something stupid. Maybe I sligtly damaged one or a few of the traces in the long flat cable? But there are no visible traces of it being damaged. And like I said, I was careful. It was just lying there flat on a desk with nothing bumping into it or whatever.

Edit: if I indeed probably damaged the cable, I can at least get one for just €15. Don’t have to pray to the ebay gods that I can find one that’s not on the other side of the planet with €100 shipping.

…if FW hurries with enabling the market place for us EU folks :wink:

Edit 2: After typing all this I decided to not just re-seat but precision-clean all the mentioned connectors once again. This fixed the issue. It’s weird that a brand new laptop had an issue that was fixed by cleaning, but who knows what happened.

Good thing this happened at a hacker space, literally one footstep away from the cleaning supplies :slight_smile:


Adding my experience here. I have a batch 1 pre-assembled laptop with Windows. Yesterday night, the keyboard stopped working. The machine booted into Windows fine and everything else seemed to be working, just no keyboard input. I couldn’t get into BIOS and rebooting did not fix the issue. Finally, I shut down the laptop, unplugged power, and left it off over night. This morning, the keyboard is working again. Any theories?

1 Like

I’m having a similar issue: my keyboard doesn’t send input, although the touchpad, fingerprint scanner, and power button are all operational. After hooking up an external keyboard, I can see that the caps lock key on the Framework will light up and turn off when I toggle it on the other keyboard.
This happened after I opened it up, similar to the original poster, after I opened it up to show it off to a friend.
I reseated the connectors and there’s no apparent damage to the cable.
Is this a known issue, or are there some obvious steps I should take to trouble shoot?

1 Like

My keyboard just stopped working today as well all of a sudden. I am running Win 11, DIY edition. I am currently running 3.10 bios and the latest drivers. Fingerprint, mousepad, external keyboard seems to work but just keyboard is dead all of a sudden. Other than opening up the unit when first got it, I had never opened it since.

edit: 30 mins later after I made this post. I thought what the heck let me try rearrange the expansion cards and see. So I took out all 4 cards (1 USB-C, 1 HDMI and 2 USB-A). I swap the cards from left to right and vice versa, and so now USB-C is now on the right side next to the power/fingerprint button. Bingo! The keyboard magically started to work again. Don’t ask me why and the strange thing is that none of the expansion cards were lose in any way.

I had a similar problem, but where only certain keys stopped working. Opened it up, blew out some dust, reseeded the connection and now things appear to be fine but it’s left me a bit on edge, as my last laptop (a 2018 mbp, most problematic computer I’ve ever owned although I suppose I’ve been relatively lucky) had ridiculous known problems in this regard… I really don’t want to have to deal with keyboard problems anymore. Don’t remember my batch number but I got the framework about a year ago. edit: ack, the keyboard stopped working again, I’ll reach out to support.

Is all problems was with win 10? Maybe there is troubles with drivers?

no, it was definitely the keyboard / the keyboard connector… they sent me a new keyboard (thanks Framework!!!) after investigating other possible issues and now everything is working great again. I’m not sure how it could have happened, as I hadn’t opened up the computer for quite a while when I suddenly started having problems… but it was definitely hardware (and I’m on linux).

1 Like

So I have been using my DIY framework for almost a year now. Last 4 reboots I have lost connection to my keyboard. The Only solution that works is to eject all the expansion cards, and then magically the keyboard returns to full function. Once the system is back up and running just reinsert the expansion cards again and no worries.

@Eric_Haskins Thanks for that. I’m on a 12th Gen i5 running Fedora and the same thing happened to me.

Holding the power button brought the system back up and let me log in but then the system would shut down again immediately and I couldn’t get any keyboard input.

Removing the expansion cards and then trying, got keyboard input and the system stopped crashing. Wish we saw something from Framework here with a consistent fix. Certainly seems like a hardware issue as it’s Windows and Fedora.

I’m having the same issue, but none of the fixes are working. The keyboard and trackpad are both completely unresponsive even after rebooting and plugging/unplugging the expansion ports. This is the second time it’s happened to me. Last time it was back to normal after being off for a few hours, so hoping that’s the case this time, but would really like this to get a fix.

I started noticing it when I upgraded to the newest firmware and os (fedora 37) so could be related to that?

My keyboard just stopped working, but the power button and touchpad were fine. Luckily I found this tread fast and popped out all my expansion ports and the keyboard started to work again. Hopefully that doesn’t happen again.

My model is i7-1260p and I run Windows 11.

This problem also just happened to me today. After months of working fine, suddenly the laptop keyboard stopped responding, even the caps lock light wasn’t illuminating when toggled via an external keyboard. An external keyboard via a USB A expansion port connector worked. The USB C expansion ports were also still working, as they were charging and providing video to an external monitor.
Unplugging all expansion ports and re-inserting them brought the keyboard back to life, so definitely worth trying this for anyone experiencing similar problems.
My system is Framework 13 DIY Edition, Intel i7-1260P, British Keyboard, Windows 11 Home.


I am having the same experience, suddenly the keyboard stopped ( maybe it’s a usb host controller issue ) responding (twice now)
I could continue working with an external keyboard but only to shut it down gracefully. As the laptop kept going into powersave mode after a couple of seconds.

1 Like

I’m also having this issue, with the same symptoms of caps lock showing on the keyboard. I’ve got the Framework 13 with 13th gen Intel core. When I set the laptop down with a small amount of force, it does a software lock, as if I’d clicked “lock screen”, even with the keyboard removed. This is kind of an insane problem to have.

I’ve tried a spare framework keyboard, same problem.

Another Data point; amd fw13/fedora

I’ve had this happen when gaming (tetris effect via proton) ; my niece and newphew reliably triggered it ; which leads me to believe it’s possibly something to do with the touchpad being touched at the same time as button mashing gong on.

Update on mine. I had two of the same laptop, and I switched the keyboards between them, which seems to have resolved the issue. As for the random sleep mode issue, that was my fault, as I was stacking the laptops on top of each other, and the magnetic sensor for each laptop was interfering with the other. I’m back to having no issues!

I was running Firefox in Fedora 40, opened a new tab and started typing in a search term when the keyboard stopped working. I put the laptop to sleep. When I woke up the laptop, I couldn’t log in again because the keyboard was still not working. I couldn’t log in with the fingerprint reader either. I held down the power button to turn the laptop off and on again but that didn’t help either. I found this post and removed all the expansion cards and booted the laptop. That worked! Thank you for the help!

I got the Framework 13 AMD batch 11 in late December 2023. It feels like it might be a USB firmware problem? Is anyone from Framework investigating the issue?

1 Like

Is this on battery power or AC? I have one USB-C power brick which seems to have some grounding issues and I can imagine touching the laptop at certain spots could lead to some leak currents in turn causing weird lockups on the hardware side. Maybe try using a different AC adapter for a while and see it the issue reappears?

The keyboard stopped working while plugged in with the original charger. I think the outlet I was plugged into might not be correctly grounded so that could very well be the cause. Thanks!