Laptop doesn't shut down on BIOS update cycle. Now what?

Yesterday, I tried installing Windows 11 Pro on my FW16 onto the primary storage (Samsung 990 Pro) with Bitlocker hardware encryption, following this procedure:
I’ve also installed the driver bundle.
Just for context: I also have a secondary storage installed, a WD SN770M, but I haven’t used that, yet.

After getting Windows installed with hardware encryption, I was satisfied yesterday and shut the laptop down normally.

I just wanted to start the machine again, but it said, there were no boot devices. I went into the BIOS, to check if the devices are present. They are.

So I thought, it would be a good idea to get the latest BIOS. So I downloaded that onto a USB stick and booted the Windows2Go from the external drive I was using during the installation.

I ran the .exe, Windows said “restarting”, but now nothing happens. It appears as if the shutdown part of the restart hasn’t been triggered on some level.

I don’t know in which part of BIOS flashing the process is in or if it even has started.

I haven’t long pressed the laptop into a power off, yet.

Now what? Can I shut it down safely?

Thanks you everybody,

After about 18 hours I powered the laptop off, started it again and the BIOS update started.

The “no boot devices” problem still remains. I will create a separate thread for that.

I’ve talked to the MS support and they were not able to help me, yet. I cannot continue to find the cause, because while trying to remove the secondary storage, to rule that out as a cause, the screw of the primary SSD broke off. That appears to be a common issue.