Laptop fails to start after BIOS update to version 3.05 (AMD)

Hello,
I’m using Kubuntu 22.10 with my AMD Ryzen 7840u. Through the KDE update center I got the suggestion to update the BIOS to version 3.05.
I started the BIOS installation and performed a restart of the laptop. After that I only got a blank/black screen. After a couple of minutes I powered off the laptop (holding the power button for 10 minutes) and started the laptop again. Again all I see is a black screen (and the white power botton LED).
I waited for another 20 minutes or so, but nothing happened.
Then I tried entering the BIOS by pressing F2 right after I restarted the laptop, but got no reactions. Also tried F12 to see if that triggers anything, still nothing.

The laptop was running fine for half a year, nevertheless I then tried just booting with a single stick of RAM (slot 0) with the same result.

Does anyone have any suggestions what else I could try before I contact support?

Thank you and best regards,
Marcel

HI and welcome.

Is it plugged in and charging and do you see any flashing lights between the expansion cards where plugged in.

Hello,
yes, the laptop was connected to the charger. At the time of the update it was charging, i.e. showing the red charging light.
In the meantime the the battery is fully charged, i.e. it shows a white light.

There were no flashing lights.

1 Like

Hello,
one correction about my initial post, it is Kubuntu 23.10 instead of 22.10.

Today I tried again to start the laptop, this time not connected to the power supply. The screen is still black. But about 1 minute after I pressed the power button I got the following LED light sequence: wggggggggggggrbgbgbggg

Info on LEDs though it is made a long time ago, for the first iteration 11th Gen intel.

I would imagine/hope the info is relevant across all boards (???)

Here’s page for 12th Gen

I’ll compare them :slight_smile:
Yeap! they are the same :white_check_mark:

Hello amoun,
thank you very much for those links! Looks like the 12 basic checks are all green :slight_smile: .
The post code should be A8, based on other discussions that I found this should correspond to SMM_ACPI_DISABLE_START. No idea what the meaning is of that. Hopefully the support can help me.

1 Like

Hello, just tried on windows 10 with the BIOS updater and experience the same issue.

After aborting the update, there is a flash on the screen saying something like “EFI error code 02” “decompress failed”

I have 100MB in my EFI partition if that makes any difference

Is that with LInux on the NVMe and Windows as extra.?
100Mb I’ve heard is not always enough to record too boot systems.

I was able to update the BIOS after making a fat32 bootable media with the bios update. Took a few tries to make the USB but it worked. So yeah, EFi Storage space issue.

Actual steps I took:

  1. Download the BIOS update zip
  2. Unzip onto a fat32 formatted USB. I wish this step was an ISO image and Windows tooling made making these bootable media easier. I ended up making a fat32 bootable media in Linux and added the boot flag to the partition.
  3. boot into USB
  4. That should be it.
1 Like

Same issue for me. I had done a successful Bios update of my AMD 7 motherboard a few weeks before. I received a new motherboard because on the slot was not working properly. I followed the same Bios update process and after the screen diplayed “process completed”, nothing. I rebooted and since then I have a black screen with the same led sequences than @Marcel_Birn

About to send back the new motherboard and consider buying a Thinkpad again… Tired of all those unstabilities…

Sorry for bumping this post again. Funnily enough I experienced the exact same issue… I was trying to update from BIOS 3.03 to 3.05, KDE update center kindly offered the package so I just uploaded all the packages. Afterwards my computer got bricked in the exact same way as the post mentioned: persistent black screen even though laptop is clearly on. Even the diagnostic LED light signal was completely same (wggggggggggggrbgbgbggg). I’m also on AMD Ryzen 7840u; system is running Debian 12 instead of Kubuntu.

If @Marcel_Birn @Pierre_van_Male you guys have somehow managed to find a solution I’d love to hear it… I’ve contacted Framework Support as well. This problem might be somewhat prevalent.

1 Like

Hello,
even together with the framework support I wasn’t able to resolve the issue.
Framework then sent me a replacement motherboard and I replaced it last Sunday. After that the laptop started again. I also updated the BIOS version to 3.05 using a thumb drive. That update worked without issues.
I think for now the only option you have is to contact framework support have some back and forth with them where they ask you to try a reset of the motherboard, check certain connectors and send them pictures of the connectors.

1 Like

Personally, I don’t get people doing any sort of firmware update from an OS. I want as little as possible interference, so I always use the most minimal methods, such as in-BIOS update or UEFI update.

1 Like

If you are also here, TL;DR: DO NOT SHUT DOWN LAPTOP. Leave it a is for a few hours and go touch some grass, to the gym whatever, just to prepare for the worst and provide time for any possible updates under black screen done.

Okay, so my story:

I have dual-boot with Ubuntu 22.04.3 and Windows 11. BIOS version is JFP30.03.03 (3.03)

1.1. Firstly, I get firmware updates in the Ubuntu software center, which should be updated BIOS from 3.03 to 3.05 during reboot.

1.2. I clicked “Update”, laptop rebooted, BIOS NOT updated, but this update has gone.

1.3. I double-checked my BIOS - it was still 3.03.

2.1. So I switched to Windows 11 and used .exe installer

2.2. After laptop rebooted I got a black screen which not respond to anything. Leave the laptop as is enabled.

2.3. I set a timer for 4 hours, just to be sure that I 100% will not corrupt any possible BIOS update by premature hard-reboot.

2.4. Found this topic and a few related topics, and after reading a few “FW Support sent me a new motherboard” my hair started slowly turning gray (as thats does not sound as “sustainable” and “repairable”)

2.5. After 4 hours awaiting I finally hard-reboot my laptop.

Laptop right before, during and right after reboot video: https://github.com/MaxymVlasov/maxymvlasov/assets/11096782/77020230-582a-4b89-b480-66091e101992

2.6. After hard-reboot it shows me next error:

Update Failed!!! 
EFI ERROR CODE: 02
Decompress failed!!!

and then successfully booted to OS.

3.1. BIOS is still 3.03, and the Ubuntu software center now has the same firmware update which previously ended without any effect.

3.2. For now I’m done with BIOS updates at least till 3.05.1/3.06 release or till I find anything that will require such updates.

1 Like

If you have a usb stick you could try the efi updater method.

Decompress failed at least means it didn’t get far at all so probably didn’t do any damage.