Laptop Not Powering on With BIOS 3.07

Hi Community,

I had a strange issue occur last weekend where my laptop would not power on from shutdown. I had to plug in AC power for it to boot up, and the battery was on 54%. I just went to boot it again today (I haven’t used it since last weekend), and the same thing occurred. This time, it wouldn’t boot even with AC power plugged in, and I had no side LEDs. I followed this guide to reset the mainboard to get it to boot. Battery was on 74%.

I am using BIOS 3.07, but I’m afraid there’s still some kind of power issue. I’m wondering if this is a known issue even on 3.07 and if anyone else is seeing a similar issue.

Running Ubuntu 21.10

Thanks All

1 Like

Sounds like a bad flash to me, I recommend contacting support about it.

Just wanted to update that this issue occurred again. I had to plug in the charger for it to boot again. 47% battery life. I will probably be contacting support about this.

@RandomUser

Thanks. I will give this a try.

@nmiles any update on this? My laptop has the same issue and tried the same fixes but no luck…

I just had the same thing happen to my laptop. I was trying to turn it on but nothing was happening when I pressed the power button. After plugging in the power cord, I saw that the power light came on and the keyboard lit up, and after a minute or two I was able to start it. When I did, I checked the battery level (since I thought it was dead) and saw it was sitting at 54%. I also noticed that the time and date were incorrect, it showed the date was 4 days behind and Windows would not update saying the internet was not connected but I was able to access websites with no issue.

Going to leave it charging until this Thursday (3/24) and leave it alone for 3-4 days to see if I can replicate this issue, then if I can I will contact support and post a reply with what they say.

Hi there. Kindly check our guide through this link: My Framework Laptop is not powering on

I would recommend submitting a ticket to our support team here: Framework | Support so they can ensure your laptop is performing as intended!

Thank you and stay safe!

@Mith - It’s been on the charger for about two days now. I’m going to take it off and use it for while. I will report back with results.

Same situation, @nmiles. Battery has half a charge left so it is not a result of battery being fully drained. I am running the latest 3.07 firmware and the unit is fully powered down when it happens.

I’ve had it fail 3 consecutive times because I haven’t used the laptop for about a week (shortest time I’ve seen it happen was 6 days powered off). Each time I’ve had to reset and charge the CMOS.

Support ticket was not helpful ignoring the fact that I described resetting and charging the laptop. They just sent a canned answer with the reset mainboard guide, which I already knew about.

This is the only deal breaker I’ve had since I received my order and can’t recommend it to others until it gets fixed.

For now, I’ve had to plug the laptop every few days (not in use) to make sure when I do want to use it off AC it will turn on

hm… I just ran into this.

  1. My laptop shipped already with 3.07. I didn’t flash it myself
  2. Went to use laptop after around a week of it being powered off, it didn’t power on.
  3. I plugged my laptop in, and was able to power it on. The battery is “missing” in the OS.
  4. I entered the bios, disconnected the battery in software. Rebooted. Entered the bios, connected the battery. Rebooted.

The battery is now showing up in Linux again with a 0% charge and “discharging” while plugged in. If I unplug the power cable it instantly powers off.

EDIT:

I followed the guide mentioned above which fixed the issue. Fully Resetting the Mainboard State - Framework Guides

The laptop turned back on with 15% charge.

So; tldr it seems like the laptop fully drains the CMOS battery AND drains the main battery when it enters this state. The BIOS settings get corrupted and you have to do the full bios reset to get it functional again.

really hope Framework gets this issue addressed (or moves to a fully open-source bios). It’s annoying and could damage your battery if it is left to drain to 0%. I opened a new support ticket detailing the above so Framework support can see a lot of people having the issue and prioritize it.

2 Likes

Yeah, my laptop was on charge for 3 days straight, turned it off overnight. The laptop doesn’t boot up again the next morning.

To get it powered back on, I have to disconnect the battery, plug in the power cable and spam the power button until I get the BIOS splash screen. Once I get to this, I can reconnect the battery and it works fine.

This is really infuriating as I use this for work and can’t get any work done in the morning with this.

Yeah, it’s with support atm. We will see what happens. Waited 2 months for a laptop that works sometimes…

Update.

It works flawlessly now.

I contacted support. Tried motherboard reset as before, but no luck.

They suggested removing and re-install the fingerprint sensor/power button. (Fingerprint Reader Replacement Guide - Framework Guides)

That seemed to get it working. I guess one of the ribbon cables wasn’t connected properly.

3 Likes

Quick Update:

I left my laptop on the charger for 48hrs after my latest post to ensure the CMOS battery gets charged up. I have not experienced any boot issues so far.

Will update this thread if the issue re-occurs.

2 Likes

I tried what framework support suggested to Mith (reconnecting the ribbon cable) and did a full CMOS recharge a week ago.

It booted today off AC with the BIOS settings retained. Clock had advanced as expected. So I am cautiously optimistic and will keep an eye on it

Recommend trying the cable if it happens to anyone else.

1 Like

Same problem. Laptop wouldn’t turn on after not using it for a few days. I figured the battery must be dead, plugged it in and it powered right up. Windows showed the battery percentage at 70% plus.

Did it again a few days later.

I’m now on 21 hours of letting it charge for 48 hours straight. Hopefully that works. I’ll probably open a support ticket if I’m still having issues after letting it charge for 2 days straight.

I had same thing, leaving it on does not work, I had to go in and remove cmos battery for a couple of minnutes to fix. No need to disconnect main battery.

1 Like

I’ve definitely been seeing a similar issue for a while, though I didn’t find this thread until now. For about a month, I’ve only been using my laptop once a week, and it’s had issues turning on every time despite having a charge on the laptop battery.
One thing I’ve noticed on my laptop, is that the RTC battery will charge about 0.02V every 12 hours on charge, and though it’s rated for 3V, it’s charging voltage is only about 2.86V. I’m no electrical engineer, and I don’t know how the charge circuit is designed for the RTC battery, but this seems low to me.
Is anyone that was seeing this issue before showing similar voltages for their RTC batteries?

1 Like

I contacted framework’s support team and this is their reply:

We recommend that you fully charge your laptop at least once every week, and to trickle charge at least every 2 weeks. The RTC battery charges continuously while the laptop is turned on - so it’s vital that the laptop is always charged(not going on low battery/drained)

If this issue is happening to everyone, I consider it as a major design flaw. And framework has to fix it.

I have a 10-year old Thinkpad laptop that can be turned on without connecting to power after several months.

3 Likes

Exactly. I’ve had many laptops that weren’t used for weeks/months at a time and they had no problem booting up as long as the main battery wasn’t completely dead. I’ve ditched the framework to populate out in my tech junk drawer for now. My primary laptop needs to be reliable for when I’m out and about without the ability to plug it in quickly.

2 Likes