Laptop Not Powering on With BIOS 3.07

This implies that the RTC battery only charges when the laptop is turned on. I would like to hear back from someone on whether this is the case, or if it does also charge with the laptop off, and plugged into the charger. As an update, I haven’t heard back from the support team since the initial response where they told me the RTC battery was likely at fault, and asked me for an update, which I did provide the next day.

2 Likes

I would agree with that. I’ve been using my laptop more lately, so it hasn’t happened to me since following the mainboard reset procedure and leaving it on the charger for 48 hrs. However, it’s still going to be a concern I have going forward since I don’t use it everyday. I’m now carrying around the screwdriver that came in the box in case It happens while on the go. I hope Framework acknowledges the issue soon.

1 Like

Chalk me up as another one having this issue. Framework support suggested an RTC Battery pull/mainboard reset and 24h of charge but I haven’t had a chance to try it yet. Not high expectations of it correcting the issue, though. So far I’ve only been using my FW at home but the first time I’m out and about and can’t boot I’m going to be ripping annoyed.

2 Likes

Just wanted to update anyone watching this thread that I have not heard from support at all this past week since I sent them my first update. I haven’t been emailing them for updates, as I have heard that bumps the issue back in their priority, so I guess I’ll wait. It’s a little surprising though since they responded a few minutes after I sent in my original support request at 1AM on Easter.

2 Likes

@John_Comeaux I am sorry to hear that you are having a poor experience with our support. We would love to make this experience better for you. Could you please DM me the email used for your ticket so I can take a look?

Our response time currently is around 1-2 business days unless it is an RMA as that may take a few additional business days :slight_smile:

Update: I have found your ticket through your name. I see we had emailed you on the 16th and we had not heard back from you. Could you please try resending your response?

2 Likes

Hi,
I’ve just had a strange experience with my batch 9/10 laptop. After leaving unpowered for a few days the laptop would not power on. charging would not work also. After doing a mainboard reset it powered on fine. However, the battery was at 13 percent. BIOS v3.07. I’m a little concerned this may become a regular occurance. I can’t understand why this would happen with so much battery life left.
Having just read this thread it seems like a fairly common problem. I certainly don’t want to have to charge frequently just to be able to use a device. If a laptop runs out of “juice”, you should be able to plug it in and use it again, anything else is a design flaw and simply not practical.
It seems as though a rechargable button cell is a weak point if it’s going to discharge so quickly.

2 Likes

For anyone that may have been watching this thread. I have not heard back from FrameWork’s support team, or @BeeAPeach as I also DM’d them having still not heard back from support. Feels like support is slacking pretty hard, not even trying to help figure out why they aren’t getting my emails.

1 Like

Have you tried using a different email address while the issues with the other provider (protonmail?) are being sorted out?

I’m also having this problem. Followed the steps on this KB article, but it didn’t get it going.

I’m going to try the mainboard reset next. I’m also on BIOS 3.07
I hope this gets sorted soon. I love my Framework laptop, but I need it to work consistently, when I leave the house.

Update: The mainboard reset worked for me.

I hope I won’t have to do this too often, though.

1 Like

Update:
After not using my laptop for an extended period, it would not boot up again and had to plug in power. It seems the RTC battery loses charge pretty easily. Until Framework acknowledges the issue and fixes it, I guess I’ll just have to be sure to throw my laptop on the charger every now and then during extended periods of not using it.

3 Likes

Yes, this is a real issue for me, I won’t remember to recharge that often. I have around 20 laptops.
Until this is sorted I may, sadly, have to give up entirely on framework. I was thinking of getting an upgraded framework, but, I don’t want to throw good money after bad.

I’m avoiding being another ‘early adopter’ of the 12th gen board. Being the early adopter of one generation of the laptop was bad enough / more time consuming than needed. I’ll wait for reviews and see what posts people will be creating in the forum…then decide if it’s worth handing more money to Framework.

It’s a real shame, I absolutely love the idea behind framework and really want to support and see them succeed. I love most everything about the laptop, the screen is supurb, as is the keyboard. The aspect ratio is my favorite ratio and I love aluminium shells. Just, please, sort out the power issues for good.

1 Like

Vegans aren’t going to be buying any veggie burgers if they taste like crap. (At the end of the day, the products still need to be good / great.)

Update:
Only 8 days after my previous update, my laptop will not power on again. This time, it won’t power on even with power plugged in. I am traveling and don’t have the screwdriver to open it up and follow the mainboard reset procedure. This is infuriating.

@BeeAPeach What can be done about this issue that I and many others on this thread are having?

This is quite annoying. I work from home, so I only use my laptop when I work away from home, which is about once a week. I don’t want to have to take apart my laptop every time I need to use it.

My question for the staff at Framework is the following: is this a hardware issue (design flaw) or is it something that can be fixed via a BIOS update?

@nmiles - sorry to hear that. I realize that the linked comment is for bios 3.06, and may or may not work, but it’s worth a try:

Good luck.

@lbkNhubert

The linked procedure does not work. It might have worked on BIOS 3.06, but I never had to try it before I upgraded to 3.07. I can say that on my laptop with BIOS 3.07, it definitely did not work.

@Domenico_Cotugno - good to know, thank you. Too bad that it won’t help. I will make sure to travel with the screwdriver for the machine.

LoL… :person_facepalming:

The slack that the community has been willing to give…too generous…almost cult-like.