Laptop Not Powering on With BIOS 3.07

I’m avoiding being another ‘early adopter’ of the 12th gen board. Being the early adopter of one generation of the laptop was bad enough / more time consuming than needed. I’ll wait for reviews and see what posts people will be creating in the forum…then decide if it’s worth handing more money to Framework.

1 Like

It’s a real shame, I absolutely love the idea behind framework and really want to support and see them succeed. I love most everything about the laptop, the screen is supurb, as is the keyboard. The aspect ratio is my favorite ratio and I love aluminium shells. Just, please, sort out the power issues for good.

1 Like

Vegans aren’t going to be buying any veggie burgers if they taste like crap. (At the end of the day, the products still need to be good / great.)

Only 8 days after my previous update, my laptop will not power on again. This time, it won’t power on even with power plugged in. I am traveling and don’t have the screwdriver to open it up and follow the mainboard reset procedure. This is infuriating.

@FrameworkBee What can be done about this issue that I and many others on this thread are having?

This is quite annoying. I work from home, so I only use my laptop when I work away from home, which is about once a week. I don’t want to have to take apart my laptop every time I need to use it.

My question for the staff at Framework is the following: is this a hardware issue (design flaw) or is it something that can be fixed via a BIOS update?

@nmiles - sorry to hear that. I realize that the linked comment is for bios 3.06, and may or may not work, but it’s worth a try:

Good luck.


The linked procedure does not work. It might have worked on BIOS 3.06, but I never had to try it before I upgraded to 3.07. I can say that on my laptop with BIOS 3.07, it definitely did not work.

@Domenico_Cotugno - good to know, thank you. Too bad that it won’t help. I will make sure to travel with the screwdriver for the machine.

LoL… :person_facepalming:

The slack that the community has been willing to give…too generous…almost cult-like.

@A_Fan - to be clear, I typically do travel with the screwdriver, additional drives, and more. I realize that’s not necessarily the typical use case, but it’s what I’ve done since long before Framework existed. I also have not run into the no power issue, fingers crossed. When I have had problems the support that I have received has been very good.

Regarding slack, I chose to purchase this machine knowing full well what I was undertaking - a new company with a first generation product. I expected that there could be growing pains and I accepted that. Given your recent posting history I am curious why you keep the laptop rather than selling it and moving on. It’s one thing to hold a high bar, in my opinion it is a different thing constantly to be a dark cloud.

No company (computer or otherwise) is perfect. If you find that your experience is not a match to your expectations, change direction and move on.

Keeping the ‘platform’…and see where it goes.

True. I don’t plan on being a popular poster here. I’ll get tired of posting eventually.

Convenient editing. I’ve traveled with a toolkit for the past 30 years. Nothing new. And yes, I needed it on occasion, for laptops of all sorts of makes and models. The snark is unhelpful. Holding a high bar? Fine. Being obnoxious (my opinion)? Not fine. You clearly have knowledge and expertise to bring to bear, why not channel it in a positive way rather than constantly presenting things in the most negative light?

Hopefully the platform evolves into something that makes you happy. No one is asking you to carry Framework’s water, and it’s fine to present a different point of view. Comments about a “cult,” evolution of the product allowing Framework to sell a substandard offering today (my paraphrase), and so on don’t help to further the discussion.

Have a good day.

Very little of any discussion furthers things in reality.

True. Don’t think I can get a refund though.

Issues…are about gap findings, negative by nature. I see the positive in some situations, and had stated so. (e.g. Modularity allows startups to grow as they fix things…it’s a good model.)

I have a strong tendency to see the negatives…but this doesn’t doesn’t mean I don’t see the positives. I just state what I see, both sides (when applicable), bluntly.

…and let’s face it, Framework has been ignoring the TB4 certification question for both 11th gen and 12th for quite some time now.

Was wondering if anyone else having this problem has tried the fix reported by @Mith (Laptop Not Powering on With BIOS 3.07 - #16 by Mith) and confirmed by @alowndar(Laptop Not Powering on With BIOS 3.07 - #18 by alowndar)?

Neither has posted to this thread or these forums since then - which could be taken as a good sign(?). Just seems like a potential solution has gotten lost inside this thread…

nmiles responded immediately after #16. I would assume* he/she is at the very least aware of it.

Ok, here’s me being a bit more constructive:
With the ribbon cable, Framework has already been using double-sided tape to minimize cable shift / movement. However, if it’s contact issue (for whatever reason) between the ribbon cable and its connector, you can try ‘shimming’ the non-contact side of the cable by applying one layer of magic scotch tape (not more, 2.2mils) to it, making it slightly thicker and therefore pushing into / up the contacts just that little bit more.

1 Like

Yes, but nothing in that post (Laptop Not Powering on With BIOS 3.07 - #17 by nmiles) shows any awareness of Mith’s suggestion.

I asked the question b/c I prefer not to make assumptions…

@ssu I would suspect that what fixed it in both those cases was the CMOS battery recharge, and not necessarily the fingerprint ribbon cable. But I’m happy to be proven wrong. :slight_smile:

For me, the positives of the Framework laptop outweigh the negatives. The only negative I have is this one. The positives are that I have a modular, “future-proof” (within reason), user-serviceable laptop that is as sleek and portable as one from a more mainstream manufacturer. I’m quite pleased with my purchase (don’t call me a cultist! :stuck_out_tongue:), even if I need to keep my laptop plugged in while I’m not using it to avoid this issue. I would be even happier if someone from Framework would speak up and tell us this will be permanently fixed, preferably via a BIOS upgrade.

@ssu - I did not try that solution at the time. However, I’ve gotten a new input cover since (RMA’d the previous one for a different issue). Maybe it is still an issue with the new input cover, I don’t know. I will try that doing that once I have the tool to open the laptop just to cross it off the list.

Maybe they will see this thread and confirm whether the issue has re-occurred for them or not.

@ssu It was a false positive. I still have the battery fail and have to do a reset or plug in the laptop to AC while in use. I’ve resigned myself to this just being the way it is for 11th gen boards.

I read in the thread about the 12th gen boards that this was improved so I can already assume the “solution” us 11th gen board users will be told is to upgrade; which is irritating.

I haven’t returned to this thread until now (I saw your mention yesterday) because I don’t believe there is an actual solution to our problem

1 Like

Man, that surely does suck…

I’m currently ‘still’ on the bandwagon for the 12th gen board…but seriously need someone to run it through before making another purchase.