Laptop suddenly stopped working/charging[SOLVED]

My laptop was delivered in early November (I think around the 4th) and has been working wonderfully during this time. Last Friday I finished finals, so it’s been sitting in my school bag until earlier this evening when I went to go watch a movie on it. At first I just assumed that the battery had died over the weekend, but afterThis text will be hidden a cursory inspection I found that it was a) not turning on even while plugged in, and b) none of the lights on the device were lighting/responding whatsoever.

things I’ve tried so far:

  • everything relevant suggested here: My Framework Laptop is not powering on
  • attempting to charge from each expansion port slot
  • attempting to charge from the charger that came with the device (functioning, charges my phone just fine)
  • attempting to charge from my phone charger
  • visually inspecting components for damage (none found)
  • cursing at it and verbally threatening the side lights to turn on

Not entirely sure when, where, how, or what the issue is as it seems to have come out of the blue without any real cause. Any other ideas and help for troubleshooting, repair, or component/unit replacement would be greatly appreciated, winter break just started so this isn’t the worst time- but I’m hopeful to have a functional laptop by the time school goes back. Thanks in advance!

Did you try the “Resolving error codes blinking out or side LEDs not coming on at all” part of that guide?

1 Like

Are you comfortable with opening it up and checking wether the battery is still connected? And while you are in there just have a look at the other main connections.
If you need help with that just let us know! :slight_smile:

@Newgefarmer - see @dmac8086’s post in this thread

Be careful with the RTC battery, apparently its holder is very fragile. There are steps here

on how to remove it. Good luck!

1 Like

It sounds like the very issue Framework officially reported as being a Bios 3.06 bug.

They recommended either contacting them directly to trial a beta Bios 3.07 that fixes the bug (whereby leaving your laptop in hibernate or shutdown for an extended period no longer bricks it), or try following the ‘if the side LED doesn’t light up’ instructions section from the knowledge base link that you posted. Hope that helps

1 Like

roger, will re-attempt the side LED part tomorrow, hopefully I just missed something the first time I tried it. Will update on how it goes, but in the event the side LED process doesn’t work, any ideas what the likely steps from there would be?

so after re-attempting what I had done earlier (remove rtc battery, confirm connections are all good) at a friend’s house, it started up just fine. Issue solved! thanks.
My best guess is being tired and stressed cause my laptop wasn’t working caused me to miss something minor the first time I tried it.


Great to hear! I am happy everything is working again!

1 Like