[SOLVED] Framework Laptop doesn't turn on

I received my Laptop a few days ago. When I started my laptop for the first time everything worked. But when I try to start it again today, absolutely nothing happens. At first I thought that the battery is dead. However, it is not because of that.
Can anyone help me?

Hi and welcome.

Please search the forum, will look for you, it’s happened to a few. The RTC | CMOS battery ML1220 is probably not charged.

You may have to do a reset.

Once done in future ensure the ML 1220 is charged frequently.

How long was it between your two uses? If it’s been a while, then the issue @amoun posted is likely the issue. If not there could be some other issue with the hardware, and I would recommend that you send a message to support. They should be able to help you out further!

@Christian7, do you have a 12th gen unit?

@Azure & @amoun
I thought 12th gen unit’s RTC battery would now be able to get charged from the main battery. Has that not been improved?

1 Like

I had thought there were still a few 11th gen units being sold, but I may be mistaken. If it is a 12th gen unit, then resetting the mainboard could still do something if there is another issue, but contacting support is still my recommendation.

not sure about the 12th gen units fixing the RTC issues. I know that the RTC can now recharge from the main battery, but I don’t know if there are other ways it can get into the state of not turning on.

Thanks, I was able to solve the problem with the tutorial

It was only two days.
I am not sure but I read in the comments of the tutotial that the twelfth gen mainboard can solve the problem

Yes but did you clarify which you have ?

I have the 11th gen mainboard (i5-1135G7)


Yes the 12thGen a) can charge form the main battery and b) doesn’t have the inbuilt 11Gen Intel chip fault that requires a main board reset.

1 Like