Laptop will not boot, not even into the BIOS

Hi everyone,

I submitted a support ticket on Sunday, but still have not gotten a response.
I can imagine it’s busy and hectic, so I thought I would reach out here to see if anyone can help me.

So this concerns, the new Framework 13 AMD laptop.
The first day I got the laptop, I installed Fedora on it, and installed the Bios update.
Afterward, I flashed Pop_OS on it, and everything was working fine, I was a happy camper.

But the following day, the laptop did not want to turn on anymore.
At first, the fingerprint light would turn on, when I pressed the power button, but then after a few minutes even that stopped working.

I’ve tried:

  • Taking out the SSD
  • Taking out and swapping the RAM modules
  • Disconnected the battery
  • Tried turning on the laptop using the power button on the main board.
  • Using a USB boot drive

Nothing seems to be working, I can’t even boot in to the BIOS.

When I plug in the charger, there is a solid red light, and sometimes the charging light would cycle through different colors (red, blue, green).
When I lift the lid, I get flashing red lights

Can anyone help me with how I can continue troubleshooting my laptop?

Side notes, the SSD and ram we’re bought together with the framework laptop from framework.

The flashing multicolor leds are a code that tell you what the board is reporting as being wrong. Still with what you describe it sounds like a hardware failure of some kind. Still Framework’s support team is top notch and I have high hopes that you’ll get squared away.

Really big bummer though that this happened right after getting everything all set up. Hang in there, and I’m pulling for you!


You can look up the meaning of the colors here:

1 Like

Is there an updated guide for resetting the main board for the 13th gen Framework?
I read somewhere that the 13th gen, doesn’t have a rtc battery, so it looks a bit different compared to the guide posted in: My Framework Laptop (Intel 11th Gen Intel® Core™) is not powering on.

shuld reset after disconecting the battery and power cabel.

1 Like

What is the color blink sequence you get?

1 Like

I’m at the office today, I’ll see if I can get the color sequence code to output later.