Laptop no longer powering on


I think I might need to get with the framework team on this one but I figured I’d ask the community first see if anyone has run into this.

Basically my issue is when I tried to power on the laptop all I get is a blinking green light and I have counted and has gone over 30 times. So I don’t think it’s any boot indicator per se. But I have tried now disconnecting the battery disconnecting CMOS disconnecting both ram sticks. I don’t see any you know burnt up capacitors or burnt up copper on The board or anything like that but for some reason it is just not powering on and sometimes I will Hit the button and it’ll just blink when I hit the button and go off. Then nothing comes up at all.
I tried connecting an external display and nothing and now I’m not quite sure what the issue could be.
I did have this thing hooked up to a USBC dongle when it died. Not quite sure what may have happened. I thought it may have burnt out the USBC port but it looked fine to me. I looked in there with a flashlight. Didn’t see any you know black connectors so I’m really not sure, just curious if anyone has run into this issue.

Welcome to the community, sorry to hear that you are experiencing problems. What version of the mainboard do you have? The 11th gen intel has an issue where the RTC battery eventually dies. If you reach out to Support they will send you a new one. Whatever board you have, your best bet will be to open a case with Support. Best of luck, hopefully you are able to get the system back up and running soon.