Laptop won't boot from an external USB drive

I got my framework assembled and plugged in my Linux boot drive and it can see the drive, but when I try to boot it I get nothing but a static cursor on the screen. I have tried many of the other mentioned ways in the community, bit none of they see to work.

Secure boot as been turned off, I can access all the bios menu and settings.

I’ve only seen this (on other computers than the Framework) if the installation media hasn’t been written properly (ISOLINUX vs. syslinux).

This is install media, correct?

How did you write it?

I am using Multisystem boot, I have been using it for years and the drives work when I test on my Lenovo X1. The grub on the usb allows for me to select the Linux ISO.

There is a EFI partition, and I have never seen this issue before this with Multiusystem USB drive. It’s been my go to for years as it allows one to put multiple ISO on the USB. But i erase my drive and used Balena Etcher to make the drive and it worked.

Thank you everyone for your assistance.