LibreOffice UI unusable and not scaling on Fedora 35 KDE

Hope this is an okay place to ask this. Using Fedora 35 KDE on my new, beautiful, hidpi Framework.

Got the system UI (icons and font) to be great and usable for every program I’ve tried so far (Firefox, Thunderbird, GIMP, Inkscape, Dolphin, Vivaldi, etc.) thanks to 1.3x scaling - except LibreOffice Calc, Impress, and Writer. Its UI isn’t scaling and makes the program almost unusable:

I’ve tried changing the icon and font size in the LibreOffice options, but the effect was minimal. I can’t find anything online to help, but then googlefu (duckduckgofu?) is not my forte. If anyone has any tips or hints for how to fix this, there’s a +1 heart in it for you <3

Seems like maybe a LibreOffice bug on KDE-with-Wayland? This is the bug report, which has some suggested workarounds, though I think ultimately it’s something that will have to be fixed within LibreOffice.

1 Like

KDE-with-Wayland gave me all sorts of nightmares with scaling. In the bottom-left-hand corner of your login screen you can switch from Wayland to X11, you’ll have a much better time with the settings on X11 and the UI for LibreOffice becomes usable.

1 Like

I had the same problem in Arch running KDE, so I dropped back into…it’s not where I want to be but I’ll be patient for them to sort of the Wayland scaling.

Thanks all for the tips! @John_Flatness Cool to see the progress! Says resolved and fixed, last modified today (2021-11-19), so perhaps that’ll mean all will be well soon.

Until the fix hits, thanks @IPGentlemann for the workaround in the meantime. I never knew such an option existed! Gotta be patient, maybe get used to the magnifier.