Linux on Framework is the DeLorean of laptops. I wanted the Miata


  1. Trackpads without two mouse buttons suck, and I don’t care if Apple does it.

  2. Wifi has to work reliably because if it doesn’t you can’t even use your fancy laptop as a tablet.

After several freshly installed recent distros, including one of the recommended ones, I find the result to be a big disappointment. I use the trackpad in non-touch mode which means that I have to press to do mouse clicks, and the location of the left and right mouse button is a complete crapshoot as far as I am concerned. I wind up hunting around random left-ish and right-ish places but the result is almost impossible to use. I absolutely have to have a wireless mouse to have any sense of utility, which is not true for my daily driver which is an ASUS ROG on windows. That trackpad also sucks compared to a mouse but it sucks much less and the apparent places to click at least stay where they are and make some kind of sense.
The wifi only works reliably in the same room as the router. In my room upstairs it drops connection every 20 or 30 minutes. I have 5 and 2.4 and sometimes it will connect to one and not the other. Which one is a crapshoot. I do not have this problem on an ancient elitebook or my ASUS, nor do I have it on an Air.

Since the wifi problem is distro-agnostic I assume that one of two things is true: the driver interface is some kind of slapped-together approximate thing because the manufacturer has not supplied the needed detail or the antenna is seriously not working. Or something else I haven’t thought of. I actually spent money to upgrade my router in order to use my laptop upstairs on 2.4 (Spectrum router won’t let you expose 2.4) but no! It didn’t even matter for the framework but everybody else upstairs had better internet as I did on my ASUS. Whine, whine, whine …

So do I load windows on this thing in order to see if there is a better trackpad driver and wifi driver in windows? For Linux, do I try to find a HW compatible wifi card that has a robust, working linux driver and just forget about the trackpad and attach a wireless mouse to the laptop with a string? I can’t find docs on the trackpad software interface with a cursory search although I haven’t yet tried to pretend to be a volume manufacturer in order to get some scraps of information from the supplier. I’m too old for this kind of bullshit that I have done over and over again many times before. I just wanted basic stuff to not suck and that has not proven to be the case for Linux on this device.

This is more than just a monetary hit: I wanted the display aspect ratio because these days everything on the web is designed to look OK on cellphones to the detriment of people looking at wide aspect ratios, and everything with a big screen has wide aspect ratios. We are living in the smartest, stupidest age for design that has ever existed, where the best ways to do some things, that used to be obvious, are passed over for new shit that is trendy and is primarily used to facilitate the extraction of rent from the masses.

The DeLorean is a great car to climb out of in the Starbucks parking lot in Palo Alto for the admiring glances but it will (probably) cost you boatloads of time and money to keep on the road. OTOH the Miata is not only fun to drive but it is actually a great car that for a “sports car” is cheap to maintain. I say that as a former owner of the latter who wanted to show up for work at the local joint with the spiffy laptop that is different from all the other aluminum laptops. The DeLorean. A really cool and innovative piece of HW.

Nope, it’s back to the Miata for me.


I read the last paragraph and now my brain is hit with confusion. I assume it’s becaeuse it’s morbin’ time.

So true.

[20 chars padding]

1 Like

I’m just trying to goad people into fixing certain things. If you live long enough you will see good designs replaced by bad ones and if you yourself are a designer it is exasperating. There was this point in time when people thought that a big touchscreen on a big vertical mounted display was the shit. Never mind the fact that ten minutes on that would make your arm fall off. The main reason for much of the bad design being foisted on the public is the demo to management. So many bad ideas come out of demos that work for 5 minutes, which is at the outer limit of the managerial attention span. Any bad idea, if manufactured in enough volume, becomes the design standard.

I don’t really blame the FW designers for the touchpad choice but I hope that one of them will read this and think about it later. And I am genuinely irked about the wifi. I find that kind of inexcusable. I’m annoyed because I really like the HW design but the one I have works poorly enough that I can’t really use it and after loading all those distros and buying a new router for one laptop with no joy I’m really kind of done.


Personally, I hate trackpads with physical buttons, so I figure that part is a user preference thing. Comparing the various Linux distros to how it behaves on a Windows machine is an apples to oranges comparison, too, so that seems iffy to me.

As for the wifi, changing distros will rarely make much of a difference, as the distros themselves aren’t responsible for the drivers. The drivers for the wireless card are written by Intel and are submitted to the Linux kernel, so really, it’s more a matter of how up-to-date the distro you’re trying is (for the most part). The AX210 does have Linux issues, yes – the forum has information on workarounds and the like. That being said, I challenge you to find a laptop with Wifi 6 support that has solid, reliable Linux drivers. It’s just not a thing yet, so complaining about poor Linux support to Framework seems silly.

This is a relatively recent device, and they’ve stuck to largely Linux-compatible stuff where they could, but I honestly don’t think it makes sense to approach a fairly-recently released laptop and expect Linux to “just work” on it. I wouldn’t expect that from any manufacturer unless they explicitly target Linux exclusively – which Framework doesn’t.

To your question about trying Windows – honestly, if you’re that miffed and you’re using another Windows machine as a reference, I’d suggest it. I dual boot Windows 11 off the storage card and it works well for me.


You could take the wifi card out of one of your other laptops and swap it in, or buy something 100% compatible for like $25. But anecdotally, I haven’t had any wifi issues apart from the known issues back around last year in kernel 5.15 or whatever (with Fedora).

The touchpad isn’t Apple quality, but I ditched my mechanical keyboard and Logitech G502 to just use the laptop’s keyboard/trackpad 24/7, so that’s saying something. I do use one finger tap to click, two finger tap to right click, three finger tap to middle click, and physically click the left side of the touchpad when I need to click things in multiple succession. I either don’t, or hardly physically click the right portion to right click – I just two finger tap, cause rarely do I ever need to right click multiple times quickly. Your muscle memory might get used to it. Mine did, and I find it quite efficient.

Edit: thanks to @jasonh for making me realize I could enable 1 finger physical click anywhere to left click, two finger physical click anywhere to right click, and three finger physical click anywhere to middle click (like on a Mac). See here for how to in Gnome/Sway.

I think I’m liking using the touchpad over a mouse for panning around with two fingers and pinch to zoom in apps like The mouse ofc still reigns supreme for precision clicking e.g. for an FPS, but for everything non-gaming, I find it more enjoyable.

I hope you’re able to achieve Miata-zen – I drive a MZ3 so I know the feeling and have with this laptop! Miatas are also highly tunable/parts swappable :smiley:

1 Like

On the trackpad: the way I use mine is like Apple’s, and I don’t mean “tap-to-click”. I click the pad anywhere with one finger for a left click, anywhere with 2 fingers for a right click, and anywhere with 3 fingers for a middle click. I wonder if you are confusing this method of use with tap to click, where you don’t have to actually press down on the touchpad, but just tap it. The downside to tap-to-click is you can’t easily drag stuff, but that is not a problem when you treat the entire surface as a button to press.

On the wifi: I bought an AX201 and I haven’t personally had trouble, but I’ve read on the forum where other people have had trouble, some say it is related to the routers. IIRC I just bought an AX201 without vPro off amazon or ebay for a few dollars and used that instead of buying one from Framework because I had heard about issues with the AX210.

There was recently a thread suggesting the Atheros “Killer 1535” so I ordered one to try off eBay for less than $10. Honestly the degree of trouble you are having with wifi makes me wonder if the antenna connector has come loose or there is a break in the antenna.

I have only used Linux on mine, mostly Ubuntu because I have 3 kids and a job and I know Debian best. The only real issue I’ve had has been battery life in sleep, which I fixed (after a lot of setup) by having the system sleep for 2 hours, then hibernate to swap.

It also might help if you could list specifics about your configuration like which Wifi card (AX201/AX210 vPro/non vPro) and which distros you have tried.


Whoa @jasonh thanks for the explanation/detail! I didn’t even realize physical 2 finger click for a right click + physical 3 finger click for middle click (like on a Mac) was possible…I just looked it up and got it working. Nice!!! Now there’s no need to muscle memory/guess where the left/right input sections are.

Here’s how in Gnome and Sway:

It was already enabled in Gnome Tweaks:
So it should work in Gnome.

But I’m using Sway, so I had to add this to my config:

input "2362:628:PIXA3854:00_093A:0274_Touchpad" click_method clickfinger

Get the name of the input/touchpad by running: swaymsg -t get_inputs and use the identifier:


Or replace the name with * to affect all inputs.

input * click_method clickfinger

Much appreciated!


I will respond to some questions later. Obviously some of this is just me blowing off steam. They say a cynic is a disappointed idealist. I appreciate not really being flamed since there are clearly aspects of this that I am not completely on top of. I have the no-vPro model which I chose because of the bleeding edge phenomenon. I had a Spectrum router then a Nighthawk that was quite well reviewed. I am used to those weird little RF connectors and even designed something once that had something similar for an RF antenna. What I haven’t done is try to compare dB numbers although that is fraught with ambiguity since it depends on certain things being done consistently on different platforms. Also I am just fed up with working on this box. In order to try the fixes mentioned I have to parse through the chronology of stuff that was written and choose how to act on it. I would say if you want your HW to be well liked on linux you might want to supply a wifi that is not iffy and does not require kernel patches (or mods…whatever the name) in order to work robustly.

@steven_suddarth er, slight correction:

You can patch/mod a kernel yourself, but there shouldn’t be a need to here. Just make sure you’re on/updated to a recent kernel version (5.15+ AFAIK should be fine), since newer kernel versions will include the fixes. The latest kernel in-use for a specific distro can vary.

To check what version you’re running, enter this in the terminal:

uname -r

There shouldn’t be any tinkering needed out of the box at least on the latest Fedora 36/Ubuntu 22.04 AFAIK.

For reference, I’m running 5.17.13 and also have the AX210 no-vPro model. It’s been working without issues since Fedora’s 5.15 release since ~December of last year IIRC.

uname -r

Here’s the AX210 thread for completeness.


I’ve been running Debian sid on my framework since receiving it in November last year. No issues with wifi at all on my end, both on the 2.4Ghz and 5Ghz band. It’s likely you just need a newer kernel which as Michael raised, is in the most recent Ubuntu, Fedora, Debian sid, or rolling release distros.

@steven_suddarth you mentioned you ran multiple distros, which were the ones you used and what was the kernel version?

For me it didn’t work reliably, until I disabled the adapter powersaving. Check if this will help you:

Here is a relevant snippet:

On manjaro this “might” live in /etc/tlp.conf. I say “might” because you never know whether some other configuration stuff that is connected to GUI apps in the environment overrides things. This is where find/xargs egrep saves you from tearing your hair out sometimes.

1 Like

A number of people have reported similar touchpad issues, and recommended opening the laptop up and nudging the touchpad a little. It sounds like a factory issue. I’m having similar issues and assumed I’m just old and unused to the “piano-hinge”. Similar to other posters, I enabled Mint’s “do other things to click” options which has been adequate.

(Wifi issues have been limited to one room, so I assume it’s that room.)

I would not recommend this laptop to someone who wants it to “just work”. That’s not the target audience, and not where it shows the greatest benefit. It’s a laptop for tinkerers and futurists. I actually have a level of excitement anticipating the next new thing they roll out. I know it’s silly; I could have bought a perfect-enough OOB solution. But today I enjoy it, and I believe I’m investing in my ‘tomorrow’ laptop as well.

(I do also believe we are paying a first-adopter tax in invested time. I’m optimistic that future generations will be easier.)


After having owned and been through the pain of many first generation laptops that were supposed to “just work” (on Windows), I feel the need to say that I’ve experienced the same or very similar issues in the past. However, there, the manufacturers weren’t present in community discussions or even acknowledged the issue(s). The knowledge/ability to fix things yourself wasn’t encouraged, and the lack of transparency created a much more frustrating experience. Here, I’ve seen many of the issues not only be acknowledged quickly, but also fixed.

First generation Alienware m11x (2010):
The Alienware came with a wifi/bt module that didn’t work well. The bluetooth connection stuttered causing my bluetooth mouse to be unusable (Razer Orochi). I ended up having to buy a different module off eBay. IIRC as it’s been a while, there were also thermal throttling issues.

Dell XPS 15 9550:
Would randomly crash/BSOD – that eventually got fixed as Dell rolled out BIOS fixes, but it took a long time. The first half year+ was utter hell.
Also, one of the USB ports wouldn’t work with a specific USB to Ethernet adapter (it worked on my other computers). I was going to try and RMA it, but first went to a Microsoft store to test if that adapter worked on one of their XPS 15s. It didn’t, and so I figured it was an entire product issue and just bought a new adapter. There were also a slew of other issues (throttling, battery bulge, random wakeups from sleep, and more).

Huawei Matebook X (2018):
Had a lot going well, but suffered from poor thermal performance, a rattle-y touchpad, and resonating keys.

These issues were on Windows which the laptops were meant to support and affected premium, top of the line laptops that were supposed to “just work”. There were manufacturer-less online communities that came together to find a fix. Bar that, I think we’d have felt hopeless having to play the random “RMA-your-laptop-game”. Dell did get better, though it took a long time.

First generation devices will probably always suffer issues – my own Framework certainly did. However, un/fortunately, I fully expected this to happen (which tangential to this thread, also plagues cars). Fortunately, they’ve all been fixed by software updates and/or physical replacements instead of having to buy a whole new laptop (which may have its own set of issues). All products will probably have some issues. I think being able to pinpoint what the issue is then solve it piece by piece is just flat out better than having to deal with the chance of a new laptop having an entirely new set of issues.
E.g. if all the components in your Framework work and you upgrade to a new motherboard, most likely all the components will continue to work.

That all being said and experiencing tons of products and laptops from other manufacturers, and seeing the difference here, I am also optimistic about the next generation(s) from Framework.


I suspect my problems have more to do with Linux itself and I have suggested that Framework sell another wifi module that is more universally used. And I have not liked the touchpad implementation which has spawned whole 'nother thread of complaints elsewhere. I have a copy of windoze 10 that I bought for VM applications and recently I am regretfully coming around to the idea of running 10 instead of linux on the framework. I have a long habit of hating windows with bedrock experience of it as a dumpster fire dating back to the 80’s. I was forced to use it and maintain servers on it by corporate america when I left university employment for more money in the late 90’s. That said, version 7 is actually tolerable as it is and version 10 becomes more or less tolerable after bloat removal and many other necessary excisions. Every few years I take a crack at trying to live in linux instead of windows because I totally believe in and embrace FOSS and this is the latest episode. I also want a hardware platform that will not become un-fixable in just a few years which is how I regard my ASUS ROG as a liability.

After I run 10 on it I will report back and close the loop on a few items that have been discussed here. In particular, does the windows touchpad driver give a better experience under default setup conditions and the same for the wifi driver. I cannot really fairly evaluate the experience of using this laptop because it’s too irritating, and I won’t spend any more time trying to get it to work. I just tried setting the low power mode off on battery operation and that had no effect on the wifi dropping problem. So I’m really, really done with linux on this laptop until I see how it functions with good drivers. Then maybe I will return to the question of making it work well for me.

BTW all the distros I tested were current as of about 2-3 weeks ago.

1 Like

Yeah I share the same sentiments (and did IT with Windows Servers/machines for a few years).

I switched to Linux fully on my XPS 15 about 2 years back and moved my installation to my Framework laptop. I’m glad to report that everything now works well on my end and seemingly for others, so I hope eventually you can make that switch and close that loop, too! Granted, a lot of the info is scattered around the forums, so feel free to PM me if you have any specific questions/need any help – I’ve kept up with most of it and a lot of it’s stored in my head, haha.

1 Like

Why not putting up a github with script that configures for linux ?
Wifi trackpad power management.
Maybe first a simple dcript that report of what is to set on those 3 topics

Receiving my FW this month, hope this topic will be untrue for me , or I will send it back. Need a real wifi connexion in 2022… for well… Work :wink:
Now wifi boards are preinstalled (and tested I hope)

Nowadays, everything should work well out of the box (at least on Fedora/Gnome). Most, if not all of my customization/setup is with SwayWM and other pieces regarding that, so that script would be quite niche. I think most if not all of the concerns (on the Linux software side, at least for me) are graveyard issues that have now been resolved. Regressions do happen, but that’s more-so regarding Linux kernel development.

As for power management, power-profiles-daemon that comes stock with Ubuntu/Fedora does a pretty good job out of the box with it’s three profiles: powersaver, balanced, and performance. However, for more fine tuning, I’ve currently settled on TLP. The Linux battery life tuning thread has a lot of good info, and here’s my latest write-up.

I hope your Framework experience goes smoothly!