Linux Wi-Fi and Intel® Wi-Fi 6E AX210 vPro®

Hello everyone. I have a brand new Framewrok DIY with a new install of Fedora 35. I ordered the Intel® Wi-Fi 6E AX210 vPro® wi-fi card and my wi-fi is really bad. Super slow, terrible connectivity. Other machines I have work great. I found out that I should NOT have ordered this card as irt does not work good with Linux. Has anyone else had this problem and did you find a work-around? I ordered the non vPro card but wondered if there is an existing workaround in place for the card I have. Thanks!

Many people seem to have speed issues with ax210.

If you have not seen it already, this thread has a lot of info.

Hope this helps.

1 Like

I’ve tried what’s in there but nothing seems to work. My kernel is 5.16.15 and 5.16 is supposed to work. Right now to be honest I am looking into returning my Framework. If anyone has some documented steps that work I’ll be glad to try them.

Just a note, the link above says that 5.12 currently is recommended. I’d suggest downgrading to that, if it works better then go with it! I hope it doesn’t come to returning it, they are very fun to work with.

FWIW, I’m on kernel 5.17.0~rc5 (haven’t rebooted yet to use rc8) but was on 5.16.* earlier, all without issues. I do have the non-vPro version, but I’m also wondering if it’s something about your router that’s not playing nice with the card. I’ve definitely heard of tons of wifi issues around card-router compatibility (particularly around WiFi 6 and 6E), and not just with this card (FWIW).

Glad I saw this. Luckily I already have another WiFi module from another laptop that I should be able to swap in if I run into this problem, and I’m planning to mostly connect through ethernet on my charger/hub combo. Those solutions might help you as well.

I have a multiboot setup with Fedora Rawhide, OpenSUSE TW, Garuda Linux, and Pop_OS with the same WiFi card as you and they all work wonderfully out of the box–no configuration needed.

Edit: Sorry, I misread–I have the non-Pro version. My mistake!

I just ordered an older AW200 to see if that works. All I can say is avoid the Pro version!

1 Like

vPro is definitely still bugged… firmware just outright crashes on Fedora and partially works on Arch. Ordered another card, hopefully it works.

Sadly I had to return my Framework. I tried 3 different wi-if cards. Never got a reliable connection. Super bummed! I loved the machine otherwise.

The vPro is not supported on Linux, as far as I am aware.

The name is a little misleading; it’s not better than the non-pro version unless you are using the added enterprise-related functionality for your work. If the machine is just for yourself, the non-Pro is the way to go.

As far as I can tell, it seems to be working on the lastest Kali release (as of this comment) running an 5.18.0 kernel.

I just installed kubuntu 22.04.1, kernel is 5.15.0-48, on a DIY with, I guess, the standard wifi module. No luck with wifi. I had Manjaro running, whcih saw the wifi out of the box. Is there a standard work around for kubuntu so that it does see the wifi?


Art Edwards

This is a big never mind. I had updated 22.04.1, but I had not rebooted. Now wifi is working perfectly. So, it looks like kubuntu 22.04.1 does, in fact, work out of the box.