Lost GRUB dual boot after updating to BIOS 3.07

I have Debian installed alongside with Windows 10 and dual boot was OK until I updated BIOS today. Currently I cannot even find my Debian installation in the boot menu. Is there anything that I can do to restore it besides installing Linux again?

This is a known issue with 3.07, it wipes your bootloader.

You either have to reinstall GRUB or if you’re lucky, it’s still there but EFI Boot Order has been reset:

If I recall correctly, that’s what happened in my case. I’m not dual booting but I installed the update via Windows running off an external drive. On reboot, it wanted to use the Windows bootloader off the external drive and since it was no longer there, failed to boot. I had to go into EFI Boot Order and find the entry for my Linux drive.

There’s mentions about how to reinstall GRUB earlier in the thread.

reinstalling the bootloader should fix it, unless partition table/data got messed up

You probably already know how, but for anyone else stumbling upon this thread, here is an easy way to reinstall GRUB without reinstalling the entire OS:

You need to boot from a linux-distro live usb. (In this example it’s Ubuntu)
Then follow the instructions from here (askubuntu.com) to install boot-repair GUI tool:

  1. Reboot the computer from live media and choose Try Ubuntu when asked.Try Ubuntu
  2. Connect to the internet, then open a terminal with Ctrl+Alt+t, paste the following commands and run them by pressing Enter:
sudo apt install software-properties-common; \
sudo add-apt-repository "deb http://archive.ubuntu.com/ubuntu $(lsb_release -sc) universe"; \
sudo add-apt-repository -y ppa:yannubuntu/boot-repair; \
sudo apt-get update; \
sudo apt-get install -y boot-repair && boot-repair

Note: You copy and run them all at once. If you want to run them individually just remove the trailing “; \”.
That’s it, the Boot-Repair window will appear!

Then follow the instructions from here to perform the GRUB repair:

  1. Click the “Recommended repair” button. When repair is finished, note the URL (paste.ubuntu.com/XXXXX) that appeared on a paper, then reboot and check if you recovered access to your OSs.
  2. If the repair did not succeed, indicate the URL to people who help you by email or forum.

Its very simple to reset, I’ve post this in other thread.

And you could identify the partitions that have to be mounted by running lsblk

just to reinstall GRUB that much work is not needed

  • incase of MBR
    simply running
grub-install /dev/<disk>

should install grub

  • incase of GPT
    after mounting the FAT partition
grub-install --efi-directory=<path_to_mount_point>

should do the trick

grub.cfg is not needed to be updated,if partition table & data are intact


Thank you all for posting solutions here. I screwed it up and ended up installing it again. In Ubuntu, you can try “Try Ubuntu” and get a terminal. In Debian, I think you can still get a shell and execute command line. Only problem is, in Debian, when I use grub-install, it says there’s no such command. I didn’t try to install it then and still don’t know whether it can be installed in that situation. Anyway, I hope next time I can figure it out. Better still, I hope the next version of BIOS software won’t wipe my bootloader.

Yes thanks for that.

Win 11 and Ubuntu 22.04
I’ve just updated from 3.07 to the unofficial 3.08 and the above worked fine.

Just added GRUB to the title :slight_smile:


1 Like

Just updated my dual-boot Framework (Win11 & Ubuntu 22.04) to the 3.10 BIOS and lost the linux option upon boot – so went into Windows and in a cmd w/ admin privileges, typed: bcdedit /set {bootmgr} path \EFI\ubuntu\grubx64.efi
Found the solution here: boot - Grub does not load after bios update - Ask Ubuntu
Worked for me – after rebooting, the grub manager was back.

Since you’re on 3.10…the alternative is to use the new F3 boot feature…it allows you to select the efi to load from the EFI partition. There, you’ll find your grubx64.efi to load GRUB, boot into your Linux environment and just setup grub that way without getting into Windows.

1 Like

I’ve found a solution using a live debian usb stick. You need to reinstall grub to make it available to in bios.

  1. Go to the advanced options in the live debian installer

  2. then choose graphical rescue.

  3. put in your root partition if you remember it.

  4. you need to know which disk has your bootloader on it. ( for my case i have only nvme0 )

  5. mount your boot/efi partition following the insturctions provided on screen.

  6. at the end there will be an option to reinstall the grub bootloader. select that option and press ENTER.

  7. Reboot.

This will probably work for any pc, but remember to backup your stuff in case anything happens.