[Solved]"Default Boot Device Missing" after update to BIOS 3.07

So I’m having trouble with my BIOS and/or SSD. I put a ticket in to support but thought I’d throw it out to the community to see if anyone knows what could be wrong:

After updating to BIOS 3.07, I get the “Default Boot Device Missing or Boot Failed” message on boot-up (image 1, below). I have Debian Linux installed on an SSD, which is a Western Digital SN750.

I installed the BIOS update using the UEFI package on a USB device. I can still boot off of USB, but the SSD specifically will not be recognised as bootable. The BIOS still sees the drive, however (image 2, below).

I have tried resetting the BIOS settings to “Optimised Default”, as well as taking out the drive and powering on and putting it back in.

Before I performed the BIOS update, I changed the boot priority settings to “First” and un-ticked the SSD in the boot device list. I don’t know if this is the cause of the problem. It doesn’t appear to be selectable after the update, regardless.

I will also mention I have tried with Quick Boot on/off and USB boot on/off. I’ve been using this SSD for work for a month so it’s not the biggest problem if I have to format but I would obviously very much prefer if that was kept as a last resort.

Image 1: https://i.imgur.com/EfAvuMN.jpg
Image 2: https://i.imgur.com/VT6CJFe.jpg

The 3.07 update wipes the EFI table. Unfortunately you have to reinstall GRUB but if you can, your data is intact.


@Fraoch Thanks I got it reinstalled and fixed :pray:

For anyone in the future, I followed this guide:

using an Ubuntu live CD (the Debian one I used wouldn’t work).


FWIW, even if boot from internal SSD was borked I was able to boot from a Live CD and had full access to the data, as expected.

Hey… I’m about to do the EFI Shell Method to update BIOS to 3.07; by burning Framework_Laptop_BIOS_EFI_3.07.zip to a FAT32 USB stick, rebooting and letting it run.

Is this what OP did?

Did you remove your SSD from the Frame first?

I think I’m gonna do THIS method, but I think I’ll remove the SSD - can’t HURT anything…

I’ve added a warning around this to the instructions in the Knowledge Base article. We are working on standing up the LVFS update process that will not face this issue.

1 Like

@Paulie420 I extracted the zip contents to a FAT32 USB stick, yes. I did not remove my SSD. I assume if you did remove the SSD then this problem wouldn’t occur, but that’s not to say there wouldn’t be any problem.

If anyone has trouble with their GRUB menu missing, I recommend using an MX Linux Live USB. They have a handy grub menu at the startup that detects other grub entries, and can boot into them.

1 Like

I changed the title to reflect that the issue was resolved just in case someone searches this issue

Hi, sorry to reopen this thread again.
I got my framework today snd plopped in the firecuda 530 1 tb drive. I installed MX Linux 21 from USB, it seemed fine at first. The only hook was, that the Installation took very long while creating the partition table.
after a reboot, it was not possible to boot from the SSD, it was possible to boot from the USB Stick.

I reinstalled the grub in the ESP partition and tried grub repair. No luck.

Reinstalled mx Linux now it boots. Things left to do : get Bluetooth working