Mouse-triggered display artifacts on arch kernel 5.16

Has anyone else had graphical issues on the latest kernel version using Arch? I’m using GNOME-wayland, with with kernel 5.16.1 and 5.16.2 the screen has huge graphical artifacts whenever I move the mouse around the left edge of the screen. Downgrading the kernel fixes the issue.

I have definitely been seeing this as well, I have not tried downgrading the kernel to see if that fixes it though.

I saw another post where someone thought it could be related to the 3.07 bios update, but I am still running 3.02.

I’ve narrowed it down to a combination of GDM, gnome-shell, mutter, and kernel 5.16. Changing any of those (lightdm instead of gdm, sway instead of gnome-shell, or kernel 5.15) will fix the flickering. I’ve reported the issue to gnome.

1 Like

Me too - it was right when I upgraded the BIOS which threw me off, but yea… my Kernel went to 5.16, too!! I have video of mine - is it the same as what ya’ll are seeing???

Yep, that’s what I experienced. Since I don’t want to bother downgrading the whole gnome ecosystem I’m just keeping my kernel frozen at 5.15.13 until the issue is resolved.

1 Like

No tearing, artifacts, etc in plasma or gnome on X11 with 5.16.x . I have to use X11 with my Nvidia graphics card in egpu setup, and hopping back and forth between X11 and Wayland kept throwing off my scaling setup, so I stick with X11 only now.

I suspect a Wayland issue. I was seeing increasingly high idle CPU and power usage with each Wayland and kernel update in 5.15.x . I wonder if if that is related…

I think I’m going to go about doing the exact same thing right now. I was having great success w/ 5.15.12. Guess I’ll just follow this thread and the open GNOME issue and hopefully notice when some fix is created.

Thanks, thread, for the help figuring this out… in the aftermath, the logs DID tell me the issue - I just got mixed up b/c it happened right when I upgdated BIOS. :confused:

I went to /var/cache/pacman/pkgs and ran a pacman -U on 5.15.12 linux and headers FILES; this ‘upgraded’ 5.16 back to 5.15 and after reboot the system is ‘fixed’. I don’t really know how to ‘hold’ it here other than not updating the system - is there a smarter way? I’ve been researching all sources I know.

. . . . . . . . .

You can tell pacman to ignore a set of packages in /etc/pacman.conf. Around line 25 you should see the following lines:

# Pacman won't upgrade packages listed in IgnorePkg and members of IgnoreGroup
#IgnorePkg   =
#IgnoreGroup =

To keep the kernel frozen, change the middle line to

IgnorePkg   = linux linux-headers

Also, you should use the pacman cache to downgrade linux-headers to the same version as linux, or it might cause issues.

Pacman will remind you whenever you update that these packages are frozen, and will show you what the newest version is, so whenever the issue is resolved you can comment out that line and updates will proceed as normal.

I did the headers, too - and thanks much for the .conf info… perfecto. Now, I’ll let the thread know if I hear of a perm fix. Appreciate ya’ll!

It doesn’t seem like the GNOME bug report is getting any traction.

In the meanwhile, it looks like linux-lts does not have these issues, and it is probably safer than the other recommendations I made in this thread, since it will be maintained with security patches.

If anyone else comes across this thread, ignore my advice to freeze the kernel - install the linux-lts and linux-lts-headers packages, and configure your bootloader to default to the linux-lts kernel (GRUB example). This way you will have kernel patches, and you will continue to have quick access to the main arch kernel to see if the issue is resolved.

1 Like

This is nice, b/c we can keep both installed and test. I thought I had tested the lts, but maybe not.

Thanks - much vyvlad.

I’m seeing this issue, too: I was able to fix it by disabling panel self-refresh, as described on the Arch Wiki page for the Framework Laptop (though obviously this isn’t ideal; hopefully this regression can be fixed in the next kernel release).


Tried re-enabling PSR on kernel 5.16.8, and the problem’s still present.

1 Like

On X11, or on Wayland?

I use X11, and do see a bit of lag (up to ~ .5 seconds at most) on first moving with the touchpad after the system has sat with no input for some time (~60 seconds?), but other than that no tearing or mouse induced issues. 5.16.8 on EndeavourOS…

On Wayland, with GNOME.

Oh heck, it’s SO much worse on 5.16.9.
It’s not even mouse-triggered anymore. It just randomly happens every 5-30 seconds.

Thanks for finding a reasonable fix for this, I can live with PSR being disabled if I don’t have to see that insane flicker all the time

A more permanent fix is being tested here

I might just keep PSR disabled anyways, but it’s good to see that this issue has been addressed