Need help installing OEM D kernel

Hey y’all, I’m currently trying to install the OEM kernel for my AMD framework 13 on Ubuntu as it’s been having the wifi and artifacts issues. But when I try to follow the documentation: linux-docs/ at main · FrameworkComputer/linux-docs · GitHub and copy the commands from the guide it gives me this error:

E: Unable to locate package linux-oem-22.04d
E: Couldn’t find any package by glob ‘linux-oem-22.04d’
E: Couldn’t find any package by regex ‘linux-oem-22.04d’

Any help would be greatly appreciated, thanks!

Install the HWE kernel. Works out of the box.

sudo apt install linux-generic-hwe-22.04

Should do it.

Just tried it, it can’t locate that package either =\

$ sudo apt install linux-generic-hwe-22.04
Reading package lists… Done
Building dependency tree… Done
Reading state information… Done
E: Unable to locate package linux-generic-hwe-22.04
E: Couldn’t find any package by glob ‘linux-generic-hwe-22.04’

be sure to run sudo apt update first, and note the version of ubuntu you installed (22.04 or 24.04 etc)

I can confirm, I was actually running 24.04 which was the issue. What ended up working for me was downloading the new mediatek drivers.

If you’re on 24.04 it will not work.
What you can do is check if there are hwe kernels for ubuntu 24.04 available with:

apt-cache search linux-hwe

it will list what HWE kernels are available.
IMHO, there won’t be any yet as 24.04 is quite fresh :slight_smile:

Right, I believe the fixes were implemented in 24.04. My point was what actually ended up fixing my wifi issues was manually downloading the new mediatek drivers and adding them to my system, in case SinisterCatFancier was running into the same issues as I was.

To be honest I was just copying the commands off the guide. I ran it with linux-generic-hwe-24.04 and it returned the message that I was already on the newest version, so that’s great.

Welcome to the community, wrong guide for the wrong release. :slight_smile: