New Framework 16 keeps on waking

Got new Framework 16 DIY laptop. It’s all good but why does it keeps on waking up randomly when the lid is closed? I checked devicemanager. I checked powercfg.

The main problem is I take the laptop to go. The other day I put my laptop in my backpack. I took an hour to get home. When I went to get the laptop, it was on and HOT in the backpack.

I suspect the issue is the same as reported in this forum where the keyboard is getting depressed while in your backpack “through” the lid.

Maybe this will help?

Set Windows to Power On / Off USB Devices in Sleep Mode | Password Recovery.

1 Like

In Linux Fedora (or at least the way I have it set up), it’s required to click the power button before any keyboard input is accepted when bringingit out of sleep. Is it done differently with different OS?

1 Like

Windows 11 has a VERY annoying default power setting on the wifi. In device manager check your wifi card. Under the power management tab, make sure that the wifi card is not allow to wake the device either with anything or with a WOL package.

I will also note that on the Framework 13, a key being depressed will not wake the laptop from sleep. Only the lid opening or the power button will do that.

Hi @Duncan_Mao ,

You can also run the command: powercfg /lastwake

from a command prompt to get a report on what exactly woke the computer up.
There are some other commands too that will list out the wake history; that one I know off the top of my head. The WiFi card issue is important to check. Thanks @Mario_Limonciello and @2disbetter

1 Like
  1. I don’t think the keyboard is waking it up. It also wakes up randomly when nobody is touching it.

  2. I’ve checked everything on Device Manager. All the “Allow this device to wake the computer” are unchecked and greyed out. It seemed this options are all disabled by default by Frame.Work. So maybe the devices are not waking the laptop.

  3. I worked powercfg and nothing is showing.

powercfg /lastwake
Wake History Count - 1
Wake History [0]
Wake Source Count - 0

powercfg /devicequery wake_armed
NONE

Annoying thing is it’s constantly waking up when in the bag and gets really hot.

This is weird.

Could the auto disable touchpad when mouse is detected be causing the wake? The wake on mouse is disabled on Device Manager. But everytime the mouse is moved, could the system do a micro switch between touchpad and mouse? Which wakes the laptop?

Looking at Event Viewer:

8:52:52
The system is entering Modern Standby
Reason: Lid.

Immediately after,

8:52:53
The system is exiting Modern Standby
Reason: Input Touchpad.

Either the touchpad or something on the input bus is trying to talk to the touchpad and it is responding.

You might try disabling the touchpad (or just unplugging it) and see if the issue goes away. That still didn’t answer if it is a hardware issue though.

Maybe something is wonky in the touchpad drivers? Can you roll back the driver’s or search for the generic Microsoft ones? That would tell you if it is software or hardware related. If it does the same thing it’s the touchpad. If it goes away it is something with the drivers.

Nope, not the touchpad. Random wake from sleep when lid is closed even when touchpad is completely disabled. Must be something else.

Solved the problem. I contacted FrameWork support about it.

I had to flash the updated BIOS when I first got the FrameWork 16 DIY. Apparently you need to reset to OPTIMIZED DEFAULT in the BIOS startup to prevent stuff like random waking from sleep.

That should be a step that’s included in the BIOS flash email I got when I first got the FrameWork 16.

1 Like

Hi there, welcome to the forums!

Please keep discussions relevant to the post at hand and be cordial to others in your responses. You can find our community guidelines here: Community Guidelines