New Framework laptop (Non-DIY) does not charge

I just received my Framework laptop, put in the four expansion cards (including the 2 USB C ones) and plugged the laptop in. No light came on, and half an hour later, neither the power brick is warm nor will the computer start. What am I doing wrong?

@Rylan_Schaeffer - check that.the main battery is fully connected and that the RTC battery is seated properly - be careful with the RTC battery, its holder is fragile. I’ll follow up with some links,

1 Like

Ok, collected the links:

Laptop won’t power on:

Battery replacement (to check that the connection is complete:

RTC battery replacement:


Thanks for these links! I didn’t order the DIY laptop. Should any of this be necessary?

Hopefully not, but there was an issue with the 3.06 bios that resulted in the machine not charging after the battery fully died, which could be resolved by trickle charging with a cell phone type charger to get to a base level, after which the regular charger would work. That’s covered in the first link. It’s possible that the battery connector is not fully seated or that there is an issue with the RTC battery holder. If you are comfortable opening up the machine, it’s relatively straightforward to check. If the RTC battery holder isn’t properly connected to the board then you’ll likely be in an RMA situation for the board. Hopefully that is not the case. Just remember that the RTC battery holder is fragile - there have been posts on here of people breaking it accidentally, so if you don’t have to fiddle with that battery, I wouldn’t. I’m pretty comfortable mucking around inside machines, and I’ve popped mine out, but I’ll admit that I was nervous while doing so and carefully following the guide.

1 Like

I tried trickle charging with the cell phone charger (both wall-to-USB-C to USB-C and wall-to-USB-A-to-USB-C), paying close attention to plugging in on the correct side. I also tried switching the Framework Power Adapter for my Lenovo Power Adapter. In all cases, neither side’s LED came on.

I really don’t feel comfortable opening the machine. Do you have any other suggestions?

Hi @Rylan_Schaeffer - I reviewed the steps in the linked article, and it looks like they have changed since I first had looked at it. Specifically, I’m referring to the following section, that now indicates plugging in a cell phone type charger then the main charger, with both connected at the same time:

If the side LED doesn’t light up

Check the specifications of the power adapter you’re using, and check if it works with other USB-C devices. You can see the required power adapter specifications here.

If you are using 3.06 BIOS (the default BIOS Batch 5 and 6 ships with), we’re investigating an issue where the system sometimes won’t charge after it drains to 0% while sleeping. If you see this occur, the current workaround until we have an updated BIOS is:

  1. Plug in a basic USB power adapter into one of the ports on the right side of the laptop. When doing this, make sure the power adapter you are using is a basic, non-USB-PD one, like an adapter that uses a USB-A to USB-C cable, like in the image below.
  2. With the other power adapter still plugged in, plug your Framework Power Adapter or other higher power USB-C power adapter into one of the ports on the left side of the Framework Laptop. The charging LED should then turn on, and you can then unplug the low power adapter from the right side of the laptop. If the charging LED does not come on after plugging the power adapter in, you may be facing a different issue and should proceed down through the rest of this Knowledge Base article.
  3. After 30 minutes of charging, boot the system, and keep the power adapter plugged in to let it charge fully.

If that did not work, either something is not fully connected or you have a hardware issue. The machine is intended to be user-serviceable, but please don’t embark on anything that you are not comfortable doing. If you don’t want to open up the machine then your next step if the above procedure did not work will be to open a ticket with the Support team. Best of luck with it.

Might be worth to remove the cards and try charging directly into the USB-C slot on the mainboard and bypass the expansion cards all together. Have you tried that?