No HDR on external 4k TV, Win 11 on 12th Gen

Hi there,

I recently got a new 4k TV, TCL 43RC630K. I have tried to use it as an external monitor on my 12 gen framework using win 11 pro. It is detected fine and automatically displays the correct resolution but it says HDR not supported in the control panel. I have tried a few different cables but no joy.
I know the TV does support HDR as it works using the internal Roku software. It would seem odd that this was not supported through HDMI but I don’t have any other device that supports it to try it.

Any suggestions would be most welcome.

Kind regards,

Seeing the same thing with a Samsung M70b (43") using HDMI out. I can get HDR to show as supported if I use the USB-C input on the display (it’s a "smart monitor). HDR obviously also works through the built-in apps. Haven’t been able to find anything telling me if I should be able to get HDR over HDMI out or not. :frowning:

Actually I got this working… On my particular screen, just switching from HDMI2 to HDMI 1 (which is the ARC port) seemed to resolve it. There’s also a feature called “Input Signal Plus” which is supposed to be turned on and has been an issue for a lot of folks, but it was already on and enabled for both ports for me. Not sure why one is working over the other with the same cable except that maybe the ARC port has more bandwidth? It looks like your screen supports eARC on HDMI1, meaning it’s likely to be the highest bandwidth port. Try that?

Just to add, I have had similar issues with my TCL TV with my desktop, sometimes it inconsistently doesn’t allow HDR. It handled HDR more often when I used a better HDMI cable (8K) with decent shielding or an optical HDMI cable. I no longer have this issue with my Sony TV. I also got strange artifacts when I tried to do 4K 60 HDR from very modern games as if the signal encoder in the TV just isn’t very stable, but it’s a TCL. It always worked perfectly with my PS5 though.