HDMI randomly stopped working

Framework 13 AMD 7640U DIY Edition
Windows 11 Pro 23H2

Worked just fine yesterday and now it doesn’t. Tried every port, multiple cables, multiple displays. Windows makes the sound as if its disconnecting, then connecting every time I plug in the cable.

I’m getting so frustrated with this laptop. First a bad display shipped, usb-c monitor isn’t supported, had an issue yesterday when after waking my laptop from sleep the screen stayed black and mouse was showing as an artifact block, had to hard reset to fix it.

I guess I probably have to contact support about this, but can anyone at least tell me if their HDMI expansion card seems to almost show up like its a removable drive? I don’t recall if I had this in my system tray icon prior to it not working.


EDIT: I would also like to note that I tested the HDMI expansion card on my previous acer laptop with usb-c and it worked just fine on that, but not on the framework.

I have two 3rd gen cards, and they both do that. It’s normal to show when plugged in I think.

As for the other things, I’m on Intel 13th gen so results may vary, but I’ll put it here in case it helps.

  • Did you select if you wanted to extend or mirror display in windows settings?

  • Did you update display drivers by any chance? The ones I got from the driver bundle were kinda buggy (especially when playing some games like Genshin Impact) so maybe check the AMD site for your drivers and try some from there.

If that doesn’t work, please do contact Framework support, they’ve been very helpful with my problems.

Yes tried extend and mirror in windows settings, made no difference.

And yes updated drivers from AMD, they had a newer version than the framework bundle but unfortunately it made no difference.

dang. hope framework support can help you then, good luck!

1 Like

Thanks, sure hope so too. Getting annoyed not being able to use my laptop with external monitors.