Not getting power+display from single cable when using my 2019 23.7-inch LG UltraFine 4K Display

I have a 2019 23.7-inch LG UltraFine 4K Display. Historically I have used this with my MacBook Pro and it charges the battery/laptop as well as displaying content on the display with a single connection.

When I use this same setup with my Framework laptop it uses the external display but does not seem to get power from the one cable (Ubuntu shows as depleting power). To compensate I am now using the power adapter and its own USB-C wire on the other side of the Framework laptop while connected to the display.

I kind of expected this to work, based on personal understandings and other forum posts. Any thoughts?

That’s very strange to me, as it should work as you expected. Assuming the LG TV’s PD output is sufficiently high wattage, I have no insights as to why this might be happening, maybe @Kieran_Levin would have an answer?

The specs I see say the display provides “85W Power Delivery” – maybe that is too much for the Framework laptop?

That’s not what should be happening, the laptop will communicate with PD-certified chargers and “request” only the power that it can receive. I have a 90W PD charger I use all the time with my FW laptop.

@Michael_Zornek if you unplug/replug the type-c cable from the display, does it start charging? The laptop should negotiate charging from the monitor.

1 Like

Multiple attempts to get both charge and display always fail. I’ve tried multiple connectors on each side and see the same behavior. Took a short video linked below. Let me know if there is anything I can do to help diagnose the behavior.

@Michael_Zornek I noticed what I think is a 2M thunderbolt cable. If you have a usb-c cable that is not thunderbolt, could you see if that works instead? Looking at the product description for your monitor it should also include a usb-c cable that is non thunderbolt as well.
I did find an issue a few weeks ago which we are planning to fix with a firmware update where thunderbolt 4 cables longer than 1M do not work correctly in all situations. thunderbolt cables onger than 1 meter include retimers, so they are different than shorter ones.


Gave this a try with two different normal USB-C cables I have. Neither did both charging and display and in fact, only one of them connected the display at all.

I’m curious what happens if you remove the usb-c card from the slot and attach the cable directly to the slot’s port.

Was this fixed in 3.07? If not, is it fixed in 3.08?

I have 3.08 and have tried it with Apple’s 2m Thunderbolt 4 cable to no avail.

Yeah, I thought as much. There’s no BIOS / firmware changelog that mentioned this has been fixed, nor when it’ll be fixed.

I got one of these too. When I try plugging into mine with the same cable I use for my macbook, charging toggles on and off repeatedly but the display never becomes active.

Using 11th Gen, Windows 11, just upgraded to 3.10 bios and drivers

The cable I have is a generic black USB-C with no thunderbolt icon so no idea if it’s actually a Thunderbolt 3 cable but plugging into the thunderbolt port on the LG and into my Macbook just works.

If I need a different cable, can you suggest links?
If I need a dock maybe? I also have DSP and HDMI expansion ports, I’d just really like to use this with the same display setups when sitting at my desk at home.