Framework 12th gen laptop no longer charging

TL;DR: FW 12th gen doesn’t charge when powered on/off with 35W charger or 65W charger or 96W PD via LG UltraFine 5K display. Orange LED is on when charger/display is connected.

I have a Framework 12th gen laptop running Arch Linux.

The laptop was charging fine using an Apple 35W USB-C charger earlier in the day.

With the 35W connected, I connected my LG UltraFine 5K display into USB-C which provides 96W charging. Normally the display doesn’t work in Linux (related thread) but today it suddenly started to work. With both connected there was no charging (but the orange LED was on).

After the display started to work, the Laptop stopped charging. If I connect only the display, or only the 35W charger, or only a 65W charger, the battery doesn’t charge. At first I thought this was a Linux issue, but the laptop doesn’t charge when powered off.

I don’t know what to do or how to troubleshoot. One thing I’ve tried is connecting the USB-C directly to the mainboard versus the USB-C modules. Orange LED turns on but nothing charges.

Looks like I fixed the charging issue; but now I can’t drive my display anymore.

I turned off the laptop completely, opened it up, and there were two red flashing lights which indicate the laptop is powered on. It wasn’t powered on, so I don’t know what was going on there.

Anyway I proceed to disconnect the battery. I then powered the laptop with just mains power connected to USB-C directly on the mainboard. That worked fine.

I then disconnect the mains power and reconnect the battery. The twin red flashing lights are not on, so that’s good. I then power my laptop off battery and that works fine. I then plug the mains power, and the charging is working.

Finally I try connecting the display and that fails to work. I’ll work on that in the related thread I posted earlier.

Thankfully the primary problem issue at hand is solved; I was worried that the Framework would refuse to charge indefinitely.