October/Batch 4 Thread


Sep 24 - Ordered
Oct 4 - preparing batch
Oct 15 - preparing to ship
Oct 19 - card charged
Oct 19 - shipment notice
Oct 21 - arrival in Ottawa, Canada 
(from NJ via Indianapolis, Indiana fedex hub)

I’ll be streaming assembly/installs (Kubuntu 21.04 etc) on Twitch later today (~6pm ET) - Twitch if you want to pop by and say hello!

My usual streaming content is programming and data science in R, although I’ve also had a recent seasonal kick of carving pumpkins on stream :jack_o_lantern:


I bought an i5 on the same day too, and my status exactly the same. So I think you’re absolutely right about the i5 units just being behind.

1 Like

I also ordered the same model on the same day - also have the same status.


Looks like tomorrow is the big day! I shipped it to work so no one steals it off my front porch.

Quick question that I never thought of until someone here pointed it out to me:
I’m getting the DIY 1165G7 and I paired that with an AX210 vpro WiFi card. I admit to not knowing anything regarding WiFi cards and I just selected it with my order, and I was asked here if the vpro would even pair with the 1165G7, but admittedly I have no clue. A quick google search said that all vpro needed to funciton was a core 2 processor and the 1165G7 is a quad-core, so I believe that means I’m good?

Would anyone care to educate me?

I think - someone will correct me if I’m wrong I’m sure - that in order to use vPro you need a CPU that also supports vPro like the Core i7-1185G7 that Framework offers as an option. Otherwise you can’t use vPro.

My guess is that the AX210 vPro will function just as a regular AX210 non-vPro if you don’t pair it with a vPro CPU.

So you should be fine, you just overpaid a bit for a feature you can’t use. :slightly_smiling_face:


Am I still on time to watch?

1 Like

Yup! Precisely. It will work anyway but without any vPro enhancement.

Got my Framework delivered today! Have spent the last several hours getting it all set up. I have pretty much everything working in Windows on one partition, and struggling through getting Linux Mint to see the wifi card on the other partition. Getting through it! Already an excellent learning experience. :smiley:

My final timeline was:
Sep. 9: Ordered DIY i5 with no RAM and no SSD; with AC Adapter and wifi
Oct. 4: Preparing to ship batch
Oct. 12: Preparing to ship order
Oct. 18: Your order shipped!
Oct. 20: Estimated delivery date from FedEx to Massachusetts
Oct. 21: Delivery!


@MikeCH lmao yeah I probably won’t start for another hour or so 2021-10-21T22:00:00Z

1 Like

Try a different kernel.

The 5.14 kernel worked for me.

Maybe it’s too new? But it works well for me.

1 Like

Yup! Found your thread there about an hour ago and switched over to Cinnamon (edge). Things seem to be working better now!



Plus obligatory word count.


Final Update!

Laptop is now up and running. Though I do have a broken arrow key. :expressionless:

Thanks for the clarification!

I guess the silver lining there is that if ever decide to upgrade the CPU on this machine, vpro will then be supported!


Woah, what happened there?

By my rough guess, the i5’s should be up to mid-Sept (haven’t seen many updates from that crew). @Bob_Barkerson @Sami_Al-halabi and @Lucas_Banting are at the tail end of the i5 queue. I’m not a Framework employee, just a guy who makes spreadsheets for no real reason.


By up to mid September do you mean that around that time was when batch 4 was sold out?

1 Like

My framework arrived about 3 hours ago!

I’m still trying to get it set up with windows, but so far it looks very portable and sleek. I love it! :slight_smile:


Well mine arrived yesterday! Working on setup. Exciting stuff!


FedEx delivered mine in the morning on the estimated arrival date. Putting it together was painless. My kids loved the little sheet of Framework stickers, and my wife’s reaction was “Oh my goodness, that is the cutest laptop and it feels amazing…” I said in another thread that having a numpad was non-negotiable for her, but now I think she might actually compromise on that, and I might be ordering another Framwork soon. :slightly_smiling_face:

I remembered what I read about initially entering the BIOS with F2 to turn off PS/2 Mouse Emulation and Secure Boot to use a Manjaro Live-USB image, so that was no problem. However, I immediately found that it wasn’t registering touchpad button clicks. The Knowledge Base suggests “pressing the bottom middle of the touchpad firmly a few times,” and that seems to have resolved my issue, although I still have to press the buttons somewhat firmly. I thought I was getting slow download and upload speeds with the wifi card, but then I tried running the same speed test on my old Windows 10 laptop, and my Framework running a Manjaro Live-USB (with zero tweaks) actually got better numbers.

I’m still trying to decide if I’m going to install Manjaro or Debian Stable…