Power Button Fails to Start Laptop after a day or three switched off

Hi All,

No real problems with DIY build.

Power is another story.


Use Windows including charging battery. Shut down Windows.
Two days later press power button, NOTHING, no light, no start.
Thought maybe had set to sleep and power drained (Doh ! )
Connected p/s waited a few seconds, pressed power, power button lights, Windows starts (Happy… ish)
BUT looked at power, plenty in the tank, so not flat battery.

Above scenario happened several times, exactly as above, p/s was needed before it would power up.

Searched and found web page on power …

None of the topics applied, only section that may have applied is…

If your power button doesn’t light up when pressed


A. Power button does light when p/s is connected.
B. Left off for a short time, anything from minutes to a day and it DOES power up

Conclusion. Can’t be a poorly or not connected lead, made during DIY assembly!

So left with the problem.

I have not tried the using two power supplies one at each side solution mentioned in the above web link as unless there is some sophisticated circuitry using two supplies like this = BIG BANG.

One possibility is I may have initially powered from the left hand side not right as I have two Micro USB (C) modules one each side. Does the initial power from the LEFT cause a problem?

I guess I can disassemble in case the poorly connected lead could be the problem.


1 Like


It should be fine, it’s perfectly safe to do this.

What version is your BIOS? The current version is 3.07.

Pet peeve, don’t call USB-C Micro USB

Micro on the left, C on the right.

What firmware revision are you on? Additionally, what’s the time set to if you start up with that issue while not near a network your device will connect to?

As an (ok Ex) electronics engineer I’m interested to know about the circuitry that allows two different p/s to be connected at the same time. Which I will try.

BIOS (Firmware) is 3.07 14/12/2021 = latest.

Time Time PC is set to? (Very interesting)

Here some oddities I have never seen in supporting Windows from version 3.

On W10 install set to GMT (I’m in the UK) and set to automatically check. I can’t say I really bothered to check the time after this…

Laptop apart from maybe one day weeks ago is always within range of 5 GHz WiFi, and when the various time and power oddities happened at home within feet of the WiFi router. Possibly once out of range for a few minutes.

At various times the time is wrong like US time 6 hours ahead which I assume is Windows default, but at 0800 today when it powered up time was correct.

The incorrect time has happened several times, each time I check the settings like GMT (adjusted for summer time) which are correct and maybe hit the time check button and it comes right.

At 0800 today powered ok and time was ok.

I had not been considering the time problem and the power problem as being in any way related; enlighten me on this one please !

I assume from the original reply that the two power supply trick is a suggestion to fixing the power button problem? Looking now for a phone charger with the correct connector :slight_smile:

I was curious if the RTC battery could at all be connected to this issue, I’m not fully sure as I’m not a Framework engineer. I also wonder if something’s tripping the battery’s shipment mode. But as far as I know, that bit is stored on a non-volatile flash chip so I doubt it. I’d look into contacting support, personally.


I have the same issue with my Framework Laptop which arrived in May 2022 with latest 3.07 BIOS. After a few days it will not power on anymore unless the power supply is connected - battery is nearly full.
Just wanted to ask if and how your issue was solved before I contact support.


The time problem and power are unrelated, it was a Windows setting (there by default) that had the location I think selected automatically and wrong.

The power problem still there, just tried and although worked last time after a few days not used, after 2 hours and 94% batter charge it would not power on.

Most likely is that I powered it from the LHS not the right when I first charged the battery.

This seems to need a reset which involves opening the case removing the RTC battery (ah ha clock related :slight_smile: ? ) as I tried the power from the left with a regular charger and the adaptive one supplied on the RHS, this didn’t work.

Tedious !


I have this issue too! Laptop at80% charge, Packed in my tough shell case in my laptop bag for about 5 or 6 days. Just take it out…wont power on. Plugged it in. No lights. Tried two power supplies, removed the modules and plugged straight in. Left for 20 mins. Nope. Still no lights.

Removed the main battery and then plugged in. Nope. Put it all back together…nope.

Dead laptop. I’ll try removing the bios battery and see what happens.

Back in 10!

Okay removed the battery and the bios battery, Plugged the bios battery back in and then the main battery and lights start a flashing.

Plugged the keyboard back in and it now powers up fine. Had to re-do the Bios settings but that was a given.

Going to keep an eye on this as its not really usable going forward if I have to pre-check my laptop will start every few days.

Interesting you had the same problem. Questions:- A. Did you contact support who may then have suggested the two power supply solution?

B. Is it possible that like me you possibly connected power the very first time on the left-hand-side of the laptop?

As I may have mentioned I did “A” and got solution “B” which didn’t work. Problem is that there are so many different power supplies that some don’t actually charge the laptop at all, and you need to use a none fast charger type, so not 100% sure if I applied the technique correctly.

I am not about to open up and remove the battery just yet but may do so in a week or three.

Your feedback on if the rest works long term would be helpful.


Nope, I’m a IT support guy myself. I get a lot of laptops in that wont charge etc. and often its the motherboard has got out of sync with the charger and battery.

That or the charger/cable is busted so you just learn to try all the configurations till they are all exhausted or one works.

So last resort was remove battery and Bios battery and then put it all back together. That worked.

I’m now leaving my laptop for 5 days to see if it happens again. If it does I’ll probably ask for a return as that’s not usable.

Either that or it need a 3.09 bios if it’s a bug.

Actually I just switched it on this minute. The power button glowed for like 30 seconds, nothing on screen and it powered off. Second press it powered on normally.

Not good. :unamused:


Mine has not been on for a couple of days but 90% charged.
Just tried it, nothing, tried again, nothing.
Back to the power supply.

It is NOT good that you have done the whole reset thing and the problem persists.

I too am in or was in IT for quite a while, little experience of laptops other than the 1/2" wad of fluff totally blocking my last laptops fan duct. Then took four hours to dismantle which at least is in the Framework’s favour being so easy to take apart.

With power connected on the left the light was off for say 20 seconds, then red, then flashing on/off then on all the time. Hitting the power button it sat there ON for say 30 seconds with a blank screen, then went off say 10 seconds, then on again and the “Framework” sign appeared and it booted. Possibly the same as previously, the odd bit being the delay as something happened when power first applied and on hitting the power button.

I had hoped that tech support would have (even if unofficially) responded to this post. My last ticket on this subject wasn’t responded to properly I was basically left to try the two power supply solution.

I will keep you posted on what I do next, and

PS Framework please respond. :slight_smile:


Welcome to the “club”. RTC: Viability of using a rechargable RTC battery

1 Like

Hi Alowndar,

Link really appreciated, and a massive number of posts on it too.
“Support” had never mentioned the rechargeable RTC battery, and being a 40 year veteran in IT and having to change the RTC battery like NEVER in most PCs I have and have supported it didn’t occur to me that was fitted and could cause a problem.

The overall problem is that as yet I have not seen an examination of all the possible causes which include.

A. Wrong original charge procedure. (initial charge from LHS not RHS)
B. Poor cable connections after opening the case
C. RTC battery going flat
D. Badly soldered RTC battery holder

C and D may be the same problem.

With so many possibilities and different combinations of solutions, including where maybe the problem was A or B and was fixed its difficult to follow any logical pattern.

I am NOT going to open the case and play with removing the connection to the main battery or remove the RTC battery, its even possible here than a bad solder joint on the RTC battery holder is “fixed” by its remove and refit, although unlikely.

What is of interest is the RTC battery voltage? How was this measured, possibly using one of the many utility progs that check various voltages. If so I will monitor mine.

Finally although tempted to replace the RTC battery with a “normal” one this may not be possible, but if it is dangerous as the circuitry may try to charge it once the voltage drops a little (after five or ten years !!! ) and which point it may go bang.

Just about to Duckduckgo (sorry Google) measuring the RTC battery voltage.

Again thanks for the link !


Yeah it’s really disappointing but I am still hoping Framework can come up with a solution for us supporters/customers.

At the end of the day it seems to me this isn’t an ‘Intel issue’ but a Framework issue.

Maybe they could supply a replacement board with a proper battery and the recharge links disconnected?

1 Like

I have had a quick look and a search on “rechargeable CMOS RTC battery” brings up lots of hits. I can’t imagine it is just one manufacturer who designs in this feature.

What I can’t find as yet is a utility that checks the voltage. The motherboard or some associated circuit MUST measure this to determine when to charge it.

Lots of utilities exist to check voltages on PCs motherboards, plus temperature etc. I looked in the UEFI BIOS I didn’t immediately see anywhere that showed voltage(unlikely) or enabled a view of its voltage.

I will continue to look for such a utility and “Framework” have a certain obligation to provide such a utility themselves as I’m sure the mobo maker probably does… goes to look at who makes the mobo…ANYONE KNOW THIS?

Microsoft have a way to check your battery status (handy and lots of stats) via Powershell. (needs Admin rights)

powercfg /batteryreport /output “C:\battery-report.html”

but this does not show the CMOS battery, although it could be useful to diagnose the problem if associated with the main battery.


1 Like

Reading the other post scattered with comments about the pros and cons of rechargeable or not the REALLY IRRITATING thing is that the problem of the rechargeable battery discharging quite quickly seems to be a KNOWN PROBLEM?

Yet support had me trying different power supplies attached to each side and potentially opening the box and disconnecting and reconnecting both batteries. NONE of WHICH would have worked.

If they know the problem then then need to own up to it and sort the problem with the various people having this problem.

The fact that not all machines have this problem would tend to point to either a design flaw i.e. some circuitry just on the limit, or a problem during manufacture; maybe faulty parts too.

The 3rd option of incorrect first charging and loose connections can’t be totally ruled out, and if this is the case then a specific route of checks and fixes needs to be published. Note here that the present info on two chargers etc. and the symptoms experienced does not fit the problems I have.

In essence it isn’t acceptable or practical to have a laptop that may need the charger to start it only days after it has been last used/charged. Nor is it acceptable or practical particularly with a laptop which is by its very nattier meant to be portable to fully charge it every time you use it in case next time it does not work.



I did a quick search for what laptops uses ML1220 as the BIOS / CMOS / RTC battery. It turns out…quite a few…like Acermate, XPS 13 /15…

So I’m not sure why we’re running into this issue. Firmware programming draining it?

1 Like

Yes quite right. I did some looking up and indeed, fairly common so I was mistaken.

However, now it begs to ask…what went so wrong here?