Power button not working unless charger is connected

my batch 2 Framework Laptop ( DIY edition ) has a problem with the power/fingerprint button. If I unplug my charger from my laptop overnight, I cannot power up the laptop by presssing the power button , … unless I re-connect the charger . Once the charger is re-connected the next day , clicking the power will lit up the button itself, and then I can see a tiny green LED on the side of the laptop flashing green multiple times , and eventually the laptop will boot up ( to Windows 11 ) . What can I do to fix this power button issue ?

1 Like

This may be of interest

1 Like

I tried full mb resetting with a 24 hrs charging 2 days ago . I disconnect it from charger for 1 day . Today I tested the power button . It works today . Thanks .


I’ve got an gen 11 Intel Framework (CIM SKU FRANBZCP08), and the reset process worked once, but the problem persists. I assume I’ll need to replace the battery?

Update: I’ve replaced the battery, and so far, everything is working again.

Similar issue with the 11th gen Intel Framework 13. I haven’t gone through the process yet; @brianary when you say you replaced the battery, are you referring to the coin cell battery (this is my assumption). If that was what elongated the fix, I might as well do it on the first try. Thanks.

@Craig_Aznoe Yes, I just replaced the button battery. I picked up a two-pack locally for about $10. Had it in and working in minutes.

1 Like

@brianary - the RTC battery is rechargeable, you might check to make sure that the replacement ones are rechargeable as well. Otherwise you may (likely?) run the risk of damaging the machine by sending charge to a non-rechargeable cell. Good luck.


The battery is an ML1220 (rechargeable) not the CR1220


Thanks for the clarification @brianary

@lbkNhubert hmm, I don’t think it’s rechargable. I’m using the Nuon 1220, so maybe I’ll look for a more suitable one. Weird that there aren’t any for sale in the Framework shop.

If you mean this one, remove as soon as possible as it may explode, it is not rechargable yet is being charged :fire:

It is in the model number [ SMCCR1220] you must use an ML 1220

WARNING It may seem OK temporarily but as the voltage drops below the charge voltage it will come under stress


Well, I got an ML1220, but in the installation process, the battery clip broke, and now I’m really screwed.

Hopefully only temporarily as the new ‘workaround’ for the ML1220 make be used in such a way as to ‘glue’ it to the socket.