Problems with monitor connections

I received my new DIY 12th Gen a couple of days ago and have been having ongoing problems with monitor connectivity. I’m running a fresh install of Fedora 36, fully updated.

I have tried:

  • DP expansion card → DP MST hub with dual HDMI outputs → dual monitors (this MST hub works fine with a desktop PC running Fedora 36)
  • DP expansion card → DP-to-HDMI cable → single monitor
  • DP expansion card → DP-to-DP cable → single monitor
  • HDMI expansion card → HDMI cable → single monitor
  • USB-C expansion card → USB-C MST hub with dual HDMI outputs → dual monitors (this MST hub works fine with my work laptop running Windows 10)

All of these methods have resulted in failure to detect the displays probably around 90% of the time. I usually use the back-right expansion card slot. Linux’s kernel logs show an almost constant stream of USB “new full-speed USB device number N” and “USB disconnect, device number N” events with the DisplayPort expansion card in that slot.

I’ve tried using other slots and it seems a bit more reliable, but I need to gather some proper results on that.

I also tried connecting the USB-C MST hub directly to the card slot motherboard connectors and again, the back right one seemed far less reliable than the other three.

Yesterday, I managed to get two monitors connected with the back-right slot → DP expansion card → DP MST hub with dual HDMI outputs configuration, then I plugged a USB 3 flash drive into the front right slot and the monitors disconnected.

Things seem very flaky and I’m wondering if I have a faulty mainboard. Does anyone else see problems like this?

I experience similar issues. I’m also on Linux (NixOS, tried multiple kernels). Also DIY 12th Gen I received recently.

On a direct HDMI connection through a expansion card, things are mostly stable, but sometimes I do experience random display issues (like random contiguous line-wise areas being painted glitchy as if the data encoding for certain piece of data failed, or a monitor got out of sync for a short moment.

On an anker usb-c hub with an HDMI output, things are getting a bit worse. And things seem to be getting even worse if I plug in my keyboard. :exploding_head:

I know that the monitor is OK, because I use it with my PC and never had any issues. All components other than Anker usb-c hub I own for a while now and didn’t experience issues with (well… maybe except the keyboard which does sometimes disconnect randomly).

I was only able to swap some components, and so some debugging and I can’t find a single faulty piece. I suspect that there’s something off w.r.t usb handling (probably drivers, not hardware) in 12th gen intel platform on Linux.

I remember reading somewhere kernel developer ranting about something being poorly handled w.r.t 12th gen intel support in Linux, but I dismissed it then and can’t find it anyomore.

One thing I didn’t mention before is that I was using inexpensive 3-way HDMI switches to connect multiple machines to my monitors, and was connecting these switches to the DVI-D input of the monitors using a passive HDMI-DVI adapter.

When I was connecting multiple computers’ native HDMI outputs to the switches, this wasn’t a problem at all. All computers would detect the monitors fine and I could switch between them at will.

When I used a USB-C to dual-HDMI MST hub, things were very unreliable. I suspect that the HDMI switches were preventing the MST hub from properly detecting what was connected. Once I removed the switches from the chain, things became much more reliable.

My current working setup is:

Framework USB-C card → USB-C to dual-HDMI MST hub → 2x (HDMI cable → HDMI-to-DVI adapter → monitor DVI-D port). The monitors are only 1920x1200@60Hz, so no issues with bandwidth limits being exceeded.