[SOLVED] Hub problem on Ubuntu on Framwork 12th gen

I purchased a Framework 12th gen DIY Edition and decided to go with Ubuntu 22.10.

Everything worked out of the box and I also did followed the guide here just to be sure.
Back at home I try to plug my good old hyper hyperdrive gen2 16-in-1 thunderbolt 3 dock and got amazed since my screen connected through DisplayPort show up flawlessly.
But, there is still one problem that I found the day after: any things others that the screen got detected.
I have sound through audio jack, a webcam/mic through USB-A as my keyboard.
I’m not well versed in Linux flavors since the purchase of the Framework was my step in that long awaited world.
Now I’m seeking for a good soul to help me figure how to make that hub stay the center of my homedesk setup.

Is someone have a clue on what to do to bring that guy steady?

My Framwork on Ubuntu didn’t react to other things that my screen plugged on a Hyper Gen 2 USB-C hub.

Suggestion: Plugin your HDMI/displayPort cable into the expansion card and remove the expansion port with the cable attached and attach it again with the cable still inside.

This worked for me, I found out about this workaround yesterday after rebooting and unplugging cable/expansion card alone did not improve my situation.

@Anachron has an actionable solution. I test a few hubs here myself, results are mixed due to the way each hub is communicating with the FW laptop.

@Anachron I just tried to plug the hub without the screen and nothing happen. I’ve tried to make a tail -f /var/logs/syslog and saw nothing more. I’ll try tomorrow to plug the screen with HDMI since I have to mess my cables to do so.
I have to confess that I am in complete dark here as I really dont know how to handle this kind of problems.
Thank you for your time and help!

1 Like

I’m also having trouble getting a 12th gen DIY linux machine to connect to a monitor through a hub, and I’ve tried two different hubs. I’m debating returning the laptop because of it. I can get the laptop to connect to the monitor when I plug the monitor directly into an expansion card, but that defeats the purpose of a hub!

@Matt_Hartley Can you offer an explanation of why the framework doesn’t play nice with some hubs? Isn’t this something that all other laptops are capable of? Can you at least offer a list of hubs that have been tested and do work with the framework?

Fair question. Some do, some do not. :slight_smile:

It’s a terrible answer, but the issue is we cannot and do not provide the same level of support for third party hubs.

We can only take ownership of issues with HDMI or DP expansion cards. The rationale is because we can control that end to end.

So here is how I do things. I own two hubs.

  • One Anker hub
  • One Lionwei hub

Both hubs provide HDMI access, however, I limit my hubs to USB-A/USB-C duties. I then use one HDMI and one DP expansion card, each on opposite sides of my Framework 12th gen.

Flawless performance. This specific 12th gen lives attached with two AOC 27in. 2k displays pushing at 2560x1440 @ 143.91Hz (144) refresh rate.

Runs like a rock start. Fedora 37.

Hopefully that clears things up as to why and what we recommend as a best practice in this situation.

I’ve put some time on this with a fellow that know how to proceed and it seems that it was a cable problem. I’m feeling stupid but glad that everything works now. It seems that the cable that I buyed especially to manage 8k display is too much for the framework. An error shown in dmesg tell that there is too much power for the USB port.

[54811.399362] usb 3-4: Device not responding to setup address.
[54811.606804] usb 3-4: device not accepting address 64, error -71
[54811.802863] usb 3-4: new high-speed USB device number 65 using xhci_hcd
[54811.851240] usb 2-3.1: new SuperSpeed USB device number 9 using xhci_hcd
[54811.874786] usb 2-3.1: New USB device found, idVendor=2109, idProduct=0817, bcdDevice= 3.c4
[54811.874802] usb 2-3.1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[54811.874808] usb 2-3.1: Product: USB3.0 Hub             
[54811.874813] usb 2-3.1: Manufacturer: VIA Labs, Inc.         
[54811.888591] hub 2-3.1:1.0: USB hub found
[54811.888937] hub 2-3.1:1.0: 4 ports detected
[54811.998891] usb 3-4: device descriptor read/64, error -71
[54812.306781] usb 3-4: device descriptor read/64, error -71
[54812.415035] usb usb3-port4: attempt power cycle
[54812.898752] usb 3-4: new high-speed USB device number 66 using xhci_hcd
[54812.898866] usb 3-4: Device not responding to setup address.
[54813.107123] usb 3-4: Device not responding to setup address.
[54813.314861] usb 3-4: device not accepting address 66, error -71
[54813.510751] usb 3-4: new high-speed USB device number 67 using xhci_hcd
[54813.510982] usb 3-4: Device not responding to setup address.
[54813.723080] usb 3-4: Device not responding to setup address.
[54813.930932] usb 3-4: device not accepting address 67, error -71
[54813.931107] usb usb3-port4: unable to enumerate USB device

Where did you read/fiugure out it was a power issue?

All I can see is a device not responding correctly to the kernel commands.

Delighted to hear this!

@Matt_Hartley I honestly don’t remember where it was but that was what my friend explianed to me. The fact is the cable that I was using before should be “better” but it is an older one that works on my Framework. Both cables works on my Macbook Pro 2019.

1 Like

I’m curious on this, do you have Ethernet? on the hub, and do you use it? i.e. on the USBC/USB-A hub? or do you seprate that one as well?

Rarely used Ethernet expansion card (prefer wifi), but if I do, I’d do it like this:

  • If I’m connected to external displays, I am plugged into power. 1x USB-C
  • 1xHDMI for display 1.
  • 1xDP for display 2.
  • Usually 1xUSB-C, but if I need Ethernet for some reason, I’d used 1xEthernet expansion card in place of USB-A.